Bug 1567750 - [RFE] Check for obsolete Ansible binaries
Summary: [RFE] Check for obsolete Ansible binaries
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Cloud Software Services (cloud.redhat.com)
Classification: Red Hat
Component: Insights - Rules
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Zhang Jiajun
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 07:23 UTC by Beat Rubischon
Modified: 2018-04-23 01:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 01:47:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Beat Rubischon 2018-04-16 07:23:05 UTC
Description of problem:

Since the release of Ansible Engine 2.4 we do no longer ship up to date binaries in the extras repo but a dedicated Ansible repo. As the content in extras usually won't be purged, customers without the knowledge of this change might run an outdated Ansible Engine binary forever.

Version-Release number of selected component (if applicable):

Insights as per April 16th, 2018

How reproducible:

always

Steps to Reproduce:
1. Follow old instructions to install Ansible
2. Run Insights

Actual results:

no warning about obsoleted Ansible Engine

Expected results:

warning about obsoleted Ansible Engine

Additional info:

https://access.redhat.com/articles/3359651
https://access.redhat.com/articles/3174981

Comment 6 Zhang Jiajun 2018-04-23 01:45:13 UTC
I made a test and could get hit in https://access.redhat.com/insights

~~~
Stability > New Ansible Engine packages are inaccessible when dedicated Ansible repo is not enabled
~~~

We can release this plugin.

Comment 7 Jaylin Zhou 2018-04-23 01:47:18 UTC
Close the bug as the rule has been released in the latest version.


Note You need to log in before you can comment on or make changes to this bug.