Bug 1567757 - No "refresh results" button in the Nodes page
Summary: No "refresh results" button in the Nodes page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: Upstream M3
: 14.0 (Rocky)
Assignee: Honza Pokorny
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 07:31 UTC by Udi
Modified: 2019-01-11 11:49 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:49:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 567911 0 None master: MERGED tripleo-ui: Revert "Remove 'Refresh results' button on the nodes page" (Iccde6d2493fe599579594755f57f4ae1974e4076) 2018-07-19 01:39:48 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:53 UTC

Description Udi 2018-04-16 07:31:31 UTC
Description of problem:
I have to press F5 in order to refresh the nodes page. There used to be a "refresh" button on the page which updated the nodes' statuses much faster - why was it removed ?


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%

Comment 1 Julie Pichon 2018-04-19 13:47:06 UTC
It looks like it was removed for UX reasons as it is no longer needed, now that the nodes are automatically updated: https://bugs.launchpad.net/tripleo/+bug/1727740

Comment 2 Liz 2018-04-25 14:36:42 UTC
@Udi - The status of the Nodes are shown inline as the action is happening. Do you still have a strong use case for needing to refresh?

Comment 3 Udi 2018-04-25 15:03:28 UTC
The GUI doesn't refresh the status automatically (for example if their status changes from the CLI). The user must either press F5 or use the "refresh" button that used to exist. F5 takes much longer...

Comment 4 Jason E. Rist 2018-04-25 15:22:16 UTC
Sounds like this is an RFE to make sure UI stays up to date with changes that might happen on the CLI, is that correct?

Comment 5 Udi 2018-05-06 09:01:19 UTC
An RFE like that would be nice, too. But this bug is just to restore the refresh functionality for the mean while.

Comment 14 Udi 2018-11-12 07:21:43 UTC
Verified: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

Comment 16 errata-xmlrpc 2019-01-11 11:49:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.