Bug 1567761 - Evolution: selecting text and clicking deletes the text
Summary: Evolution: selecting text and clicking deletes the text
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 07:44 UTC by Gwendal
Modified: 2019-02-01 13:23 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 10:11:59 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 794723 0 None None None 2018-04-16 10:11:58 UTC

Description Gwendal 2018-04-16 07:44:36 UTC
Description of problem:

When writing an email, selecting text then clicking will delete the selected text. And this deletion cannot be undo-ed.


Version-Release number of selected component (if applicable):

3.28.1 (3.28.1-2.fc28) 

How reproducible:

Always

Steps to Reproduce:
1. Create new email (or answer one)
2. Select text
3. Click anywhere in the text buffer

Actual results:

The selected text gets deleted.

Expected results:

The selected text should not be deleted.

Comment 1 Milan Crha 2018-04-16 10:11:59 UTC
Thanks for a bug report. This had been fixed upstream already, please see [1] for further details.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=794723

Comment 2 Olivier Crête 2019-01-31 21:44:09 UTC
Any chance we can get an updated webkit with this patch into Fedora 29? This is very much a blocker for using Evolution-on-Wayland ?

Comment 3 Milan Crha 2019-02-01 06:48:57 UTC
I guess you speak of https://bugzilla.gnome.org/show_bug.cgi?id=794723#c14 , but the next comment there says it's not a WebKitGTK+ fix, but gtk3 fix. Unfortunately, there's not much interest from gtk+ developers: https://gitlab.gnome.org/GNOME/gtk/issues/1447 It can be either they do not run Wayland or they do not use WebKitGTK+ as an editor.

Comment 4 Olivier Crête 2019-02-01 10:29:10 UTC
Any chance we can at least get a downstream patch in Fedora for this until upstream gets its act together?

Comment 5 Milan Crha 2019-02-01 13:23:56 UTC
I'm not the gtk3 maintainer, thus it's not a question on me, but I'm wondering, which downstream patch do you mean, please? Every reference I gave is to upstream. The gitlab.gnome.org issue 1447 does contain some proposals, but nothing approved by the developers. It can cause issues due to that.


Note You need to log in before you can comment on or make changes to this bug.