Bug 1567854 - [APB] apb init --dep option does not work
Summary: [APB] apb init --dep option does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Dylan Murray
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 10:04 UTC by sunzhaohua
Modified: 2018-07-30 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:21 UTC

Description sunzhaohua 2018-04-16 10:04:58 UTC
Description of problem:
apb init  --dep  option does not work 

Version-Release number of selected component (if applicable):
openshift:3.10
apb: 1.2.1

How reproducible:
Always

Steps to Reproduce:
1.  apb init my-dep-apb --dep docker.io/mariadb:latest
2.   cd my-dep-apb
3.   cat apb.yml

Actual results:
use --dep option, dependencies does not show in apb.yml. 

version: 1.0
name: my-dep-apb
description: This is a sample application generated by apb init
bindable: False
async: optional
metadata:
  displayName: my-dep
plans:
  - name: default
    description: This default plan deploys my-dep-apb
    free: True
    metadata: {}
    parameters: []

Expected results:
use --dep option, dependencies: ['docker.io/mariadb:latest'] should show in apb.yml. 

Additional info:

Comment 1 Dylan Murray 2018-04-25 20:29:48 UTC
Confirming that I see the same. Looks like the dependency functionality has been stripped from init.

Comment 3 David Zager 2018-04-27 23:40:12 UTC
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=679545

brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/apb-tools:v3.10.0-0.16.0.4

Comment 4 sunzhaohua 2018-04-28 06:08:53 UTC
Verified with latest image in brew. 
Will wait for the rpm ready to double verify.

# apb init my-dep-apb --dep docker.io/mariadb:latest
groupadd: GID '0' already exists
usermod: group 'apb' does not exist
Initializing /mnt/my-dep-apb for an APB.
Generating playbook files
Successfully initialized project directory at: /mnt/my-dep-apb
Please run *apb prepare* inside of this directory after editing files.

# cat my-dep-apb/apb.yml 
version: 1.0
name: my-dep-apb
description: This is a sample application generated by apb init
bindable: False
async: optional
metadata:
  displayName: my-dep
  dependencies: ['docker.io/mariadb:latest']
plans:
  - name: default
    description: This default plan deploys my-dep-apb
    free: True
    metadata: {}
    parameters: []

Comment 5 sunzhaohua 2018-05-03 03:39:35 UTC
Verified 

# apb version
Version: apb-1.2.5

# apb init my-dep-apb --dep docker.io/mariadb:latest
Initializing /mnt/my-dep-apb for an APB.
Generating playbook files
Successfully initialized project directory at: /mnt/my-dep-apb
Please run *apb prepare* inside of this directory after editing files.

# cat my-dep-apb/apb.yml 
version: 1.0
name: my-dep-apb
description: This is a sample application generated by apb init
bindable: False
async: optional
metadata:
  displayName: my-dep
  dependencies: ['docker.io/mariadb:latest']
plans:
  - name: default
    description: This default plan deploys my-dep-apb
    free: True
    metadata: {}
    parameters: []

Comment 7 errata-xmlrpc 2018-07-30 19:13:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.