Bug 1567864 - `quota list` command displays 'N/A' when root of the volume is empty
Summary: `quota list` command displays 'N/A' when root of the volume is empty
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota
Version: rhgs-3.4
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: hari gowtham
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On: 1408359
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 10:14 UTC by Vinayak Papnoi
Modified: 2018-09-17 04:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1408359
Environment:
Last Closed: 2018-09-17 04:53:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vinayak Papnoi 2018-04-16 10:14:50 UTC
+++ This bug was initially created as a clone of Bug #1408359 +++

Description of problem:
Even after setting a particular quota limit on '/' i.e, root of the volume, subsequent quota list command displays 'N/A' as usage limit for '/'.

How reproducible:
Always

Steps to Reproduce:
1. Apply https://review.gluster.org/#/c/12256/ on top of master branch.
2. Build and install GlusterFS
3. Run the attached test case named 'failing-test-case.t'

Actual results:
EXPECT_WITHIN $MARKER_UPDATE_TIMEOUT "10.0MB" quota_list_field "/" 5
not ok 6 Got "N/A" instead of "10.0MB", LINENUM:17

Expected results:
Tests should complete successfully.

Additional info:
As of now root of the volume is non-empty as we were having .trashcan directory created by default. But with the patch mentioned in 'Steps to Reproduce' this behaviour is being targeted to change by 3.10. See https://github.com/gluster/glusterfs/issues/65 for more details.

A modified test case named 'passing-test-case.t' is also attached which runs successfully by creating a test file at root of the volume.

--- Additional comment from Anoop C S on 2016-12-22 23:50 EST ---



--- Additional comment from Sanoj Unnikrishnan on 2017-07-27 09:33:24 EDT ---

THe issue is that the root path does not have the size xattr and hence in both 
print_quota_list_from_mountdir and print_quota_list_from_quotad, we print N/A (print_quota_list_empty) if the size xattr is not found. A stat on the root path does not still heal the size xattr. Needs to RCA fruther.

--- Additional comment from Sanoj Unnikrishnan on 2017-11-03 05:59:55 EDT ---



--- Additional comment from Sanoj Unnikrishnan on 2017-11-10 00:42:59 EST ---


Note You need to log in before you can comment on or make changes to this bug.