Bug 1567884 - deprecating katello-backup in not necessary [NEEDINFO]
Summary: deprecating katello-backup in not necessary
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Backup & Restore
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Lucie Vrtelova
URL:
Whiteboard:
Depends On:
Blocks: 1569672
TreeView+ depends on / blocked
 
Reported: 2018-04-16 11:04 UTC by Sean O'Keeffe
Modified: 2019-11-05 19:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 19:11:48 UTC
Target Upstream Version:
egolov: needinfo? (mmccune)


Attachments (Terms of Use)

Description Sean O'Keeffe 2018-04-16 11:04:30 UTC
Description of problem:

Satellite 6.3 has deprecated katello-backup and katello-restore in favor of satellite-*. This should not have been deprecated but instead symlinks created for satellite-* binaries, just like we do for satellite-installer.

Changing the name of a binary only serves to irritate customers, creating symlink allows:
- customers to take advantage of upstream community tooling
- less painless upgrades, especially considering this change is not documeneted in the release note! https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html-single/release_notes/

Comment 1 Brad Buckingham 2018-04-17 14:46:59 UTC
Hi John,

Any thoughts on this one?

You may be able to provide some background on why deprecation was chosen over symlinks.

Comment 8 John Mitsch 2018-04-19 18:38:31 UTC
Opened up a MR for this and a BZ to deprecate the scripts for foreman-maintain functionality here: https://bugzilla.redhat.com/show_bug.cgi?id=1569672

Comment 9 Brad Buckingham 2018-05-01 21:44:30 UTC
John,

Does the change in scope for bug 1569672 affect this one?

Comment 10 John Mitsch 2018-05-02 13:03:34 UTC
I can change the MR to fix both this and https://bugzilla.redhat.com/show_bug.cgi?id=1569672

Comment 12 Bryan Kearney 2019-11-05 19:11:48 UTC
This was delivered in 6.5 by 1607304. Since 6.3 is now EOL I am closing this out as CURRENT_RELEASE.


Note You need to log in before you can comment on or make changes to this bug.