Bug 1567918 - xinit script unbound variable
Summary: xinit script unbound variable
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-xinit
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Karol Herbst
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 12:32 UTC by Michal Odehnal
Modified: 2021-02-15 07:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-15 07:38:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michal Odehnal 2018-04-16 12:32:06 UTC
Description of problem:
Adding set -u to a user's .profile does not allow a them to log in on the graphical console.

Version-Release number of selected component (if applicable):
dbus-1.10.24-7.el7.x86_64
xorg-x11-xinit-1.3.4-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add 'set -u' in user's $HOME/.profile
2. Login as same user in runlevel 3
3. Execute startx.

Actual results:
/etc/X11/xinit/xinitrc-common: line <number: variable_name>: unbound variable

Expected results:
No errors.

Additional info:
Same issue is on multiple lines. Once workaround in form of
[ -z ${<variable_name>-} ] is applied, the issue is solved and I am able to log in the graphical session.

Comment 4 RHEL Program Management 2021-02-15 07:38:26 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.