Bug 1567934 - [Netvirt] IPv6 NA packet is sent out with wrong solicited flag
Summary: [Netvirt] IPv6 NA packet is sent out with wrong solicited flag
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Sridhar Gaddam
QA Contact: Itzik Brown
URL:
Whiteboard: odl_netvirt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 12:50 UTC by Sridhar Gaddam
Modified: 2018-10-18 07:20 UTC (History)
5 users (show)

Fixed In Version: opendaylight-8.0.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:51:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight gerrit 69786 None None None 2018-04-16 12:52:09 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:45 UTC

Description Sridhar Gaddam 2018-04-16 12:50:04 UTC
Description of problem:
ODL IPv6 Service supports Neighbor Discovery for Router interfaces.

A Neighbor Solicitation (NS) packet may contains IPv6 Source Address as one of the following 
:: --> Unspecified
SLL --> Source Link Local Address

When NS packet is punted to the ODL controller, it will prepare the Neighbor Advertisement (NA) packet and it will send this NA to NS initiated nodes.
NA packet contains IPv6 Destination Address and it has to be appropriately set.
FF02::1 --> All node multicast IP address (FLAGS: R:1, S:0, O:1)
Dest_LLA --> Destination LLA taken from NS (FLAGS: R:1, S:1, O:1)

It is seen that ODL controller is setting Solicited Flag=1 for All node multicast IPv6 address, which is creating issues in IPv6 connectivity.

Version-Release number of selected component (if applicable):
ODL Oxygen release

How reproducible:
Always

Steps to Reproduce:
1. Create an IPv6 neutron tenant network and associate it with the router.
2. Spawn a VM on that network. 
3. Verify that VM successfully acquires an IPv6 address.
4. Now try to ping6 to the neutron router interface.

Actual results:
Sometimes ping6 to neutron router interface fails.

Expected results:
Ping6 to neutron router interface should be successful.

Comment 10 Itzik Brown 2018-05-02 11:07:07 UTC
Checked with:
opendaylight-8.0.0-9.el7ost.noarch

Ensured ping6 to the router's interface

Also checked traffic on the tap of the VM:
fa:16:3e:33:0c:ae > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 110: fe80::f816:3eff:fe33:cae > ff02::1: ICMP6, router advertisement, length 56

Comment 13 errata-xmlrpc 2018-06-27 13:51:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.