Bug 1567970 - Multiple networkPluginName entries in node config file
Summary: Multiple networkPluginName entries in node config file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 13:54 UTC by Kenjiro Nakayama
Modified: 2018-07-30 19:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Duplicate networkPluginName entries have been removed from node-config.yaml. The duplication was necessary only for OCP 3.2 and older.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:21 UTC

Description Kenjiro Nakayama 2018-04-16 13:54:49 UTC
Description of problem:
- After installed openshift, two networkPluginName entries.


Version-Release number of the following components:

  # rpm -qa |grep openshift-ansible
  openshift-ansible-playbooks-3.7.42-1.git.2.9ee4e71.el7.noarch
  openshift-ansible-filter-plugins-3.7.42-1.git.2.9ee4e71.el7.noarch
  openshift-ansible-lookup-plugins-3.7.42-1.git.2.9ee4e71.el7.noarch
  openshift-ansible-roles-3.7.42-1.git.2.9ee4e71.el7.noarch
  openshift-ansible-3.7.42-1.git.2.9ee4e71.el7.noarch
  openshift-ansible-docs-3.7.42-1.git.2.9ee4e71.el7.noarch
  openshift-ansible-callback-plugins-3.7.42-1.git.2.9ee4e71.el7.noarch


How reproducible: 100%

Steps to Reproduce:
1. Install openshift cluster - e.g:

    # ansible-playbook /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml


Actual results:

- There are two entries of networkPluginName in /etc/origin/node/node-config.yaml

  networkPluginName: redhat/openshift-ovs-subnet
  # networkConfig struct introduced in origin 1.0.6 and OSE 3.0.2 which
  # deprecates networkPluginName above. The two should match.
  networkConfig:
     mtu: 1450
     networkPluginName: redhat/openshift-ovs-subnet


Expected results:

- Only one networkPluginName entry under networkConfig.

Comment 3 Wenkai Shi 2018-05-16 07:08:40 UTC
Verified with version openshift-ansible-3.10.0-0.46.0.git.0.85c3afd.el7, the deprecated one has been removed.

# grep -n -B 3  "networkPluginName" /etc/origin/node/node-config.yaml
46-masterKubeConfig: node.kubeconfig
47-networkConfig:
48-  mtu: 1450
49:  networkPluginName: redhat/openshift-ovs-subnet

Comment 5 errata-xmlrpc 2018-07-30 19:13:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.