Bug 1567982 - Missing flash message after network router delete operation
Summary: Missing flash message after network router delete operation
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: All
OS: All
medium
low
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Dave Johnson
URL:
Whiteboard:
: 1609213 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 14:05 UTC by Dmitry Misharov
Modified: 2019-08-22 00:54 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-20 14:26:42 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Dmitry Misharov 2018-04-16 14:05:43 UTC
Version-Release number of selected component (if applicable):
5.9.2.2.20180410215257_6961422

How reproducible:
Always

Steps to Reproduce:
1. Add a provider.
2. Navigate to Networks/Network routers.
3. Add a network router.
4. Delete the network router.

Actual results:
A flash message that informs a user about deleting is missing.

Expected results:
There should be the flash message.

Comment 2 Harpreet Kataria 2018-04-16 20:50:53 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/3775

Comment 3 CFME Bot 2018-04-17 07:33:08 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/0de86d02e9a2c9e2dff70aa14afa32009edc5d7b
commit 0de86d02e9a2c9e2dff70aa14afa32009edc5d7b
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Apr 16 16:45:14 2018 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Apr 16 16:45:14 2018 -0400

    save/render flash message after Network Router delete is initiated.

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1567982

 app/controllers/network_router_controller.rb | 2 +
 spec/controllers/network_router_controller_spec.rb | 14 +-
 2 files changed, 15 insertions(+), 1 deletion(-)

Comment 5 Scott Seago 2018-08-29 20:27:33 UTC
*** Bug 1609213 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.