Bug 1567985 - linux-firmware-20170606-58.gitc990aae.el7_4 Missing "Requires" for "coreutils" in .SPEC
Summary: linux-firmware-20170606-58.gitc990aae.el7_4 Missing "Requires" for "coreutils...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: linux-firmware
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Bruno Meneguele
QA Contact: Rachel Sibley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 14:06 UTC by Gregory Young
Modified: 2019-02-19 23:38 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-05-21 17:50:25 UTC


Attachments (Terms of Use)

Description Gregory Young 2018-04-16 14:06:14 UTC
* Description of problem:

linux-firmware-20170606-58.gitc990aae.el7_4 adds some code to put the Spectre rollback readme file on the target device. This introduces the "cat" command to the %post scripts. This command is part of the "coreutils" package, but this package was not added on the (missing) "Requires:" line of the .spec file. On fresh install with an .iso built with this version of the linux-firmware package, a warning is generated and the package install is marked as a failure.

* Version-Release number of selected component (if applicable):

20170606-58.gitc990aae.el7_4

* How to reproduce:

Add linux-firmware-20170606-58.gitc990aae.el7_4.noarch.rpm to a 7.4 .iso image (replacing the stock version), then perform an install (I'm using a kickstart file). Check the anaconda logs (packaging.log) for the warning.

* Actual results:

warning in packaging.log:

02:52:40,898 INFO packaging: linux-firmware-20170606-58.gitc990aae.el7_4.noarch (226/591)

02:52:40,898 INFO packaging: /var/tmp/rpm-tmp.mzWjsZ: line 9: cat: command not found

02:52:40,898 INFO packaging: warning: %post(linux-firmware-20170606-58.gitc990aae.el7_4.noarch) scriptlet failed, exit status 127


* Expected results:

No warnings.

Comment 2 Bruno Meneguele 2018-05-21 17:50:25 UTC
Hi Gregory,

thanks for the report! The issue was already solved on -61 release of linux-firmware on behalf of another bug. Because of that this BZ is being closed as CURRENTRELEASE.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.