Bug 1568000 - Cannot run VM with sysprep floppy attached
Summary: Cannot run VM with sysprep floppy attached
Keywords:
Status: CLOSED DUPLICATE of bug 1567773
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 14:38 UTC by Petr Matyáš
Modified: 2018-04-16 14:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 14:47:30 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Petr Matyáš 2018-04-16 14:38:56 UTC
Description of problem:
When I try to run once a VM with sysprep floppy attached I get
(<Element 'disk' at 0x7f0df04240d0>, 'driver') error with no actual description of what is wrong. There are some exceptions in vdsm log, copied in additional info.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.3-0.1.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. create windows VM with a disk
2. try to run it with Run Once and set floppy to sysprep
3.

Actual results:
VM is down

Expected results:
VM is up with sysprep floppy attached

Additional info:
2018-04-16 16:03:35,853+0200 ERROR (vm/bc823116) [virt.vm] (vmId='bc823116-d26f-47f4-97fd-652c7856bc09') The vm start process failed (
vm:943)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 872, in _startUnderlyingVm
    self._run()
  File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 2861, in _run
    domxml = hooks.before_vm_start(self._buildDomainXML(),
  File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 2246, in _buildDomainXML
    self, dom, self._devices[hwclass.DISK])
  File "/usr/lib/python2.7/site-packages/vdsm/virt/domxml_preprocess.py", line 197, in update_disks_xml_from_objs
    dev_elem, disk_obj, vm.log, replace_attribs=True)
  File "/usr/lib/python2.7/site-packages/vdsm/virt/vmdevices/storagexml.py", line 300, in update_disk_element_from_object
    driver = vmxml.find_first(disk_element, 'driver')
  File "/usr/lib/python2.7/site-packages/vdsm/virt/vmxml.py", line 112, in find_first
    raise NotFound((element, tag,))
NotFound: (<Element 'disk' at 0x7fb4582e3150>, 'driver')

and also I can see this traceback

2018-04-16 16:03:37,392+0200 ERROR (libvirt/events) [vds] Error running VM callback (clientIF:683)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/clientIF.py", line 646, in dispatchLibvirtEvents
    v.onLibvirtLifecycleEvent(event, detail, None)
AttributeError: 'NoneType' object has no attribute 'onLibvirtLifecycleEvent'

Comment 2 Petr Matyáš 2018-04-16 14:47:30 UTC

*** This bug has been marked as a duplicate of bug 1567773 ***


Note You need to log in before you can comment on or make changes to this bug.