Bug 1568021 - Clementine crashes when playing an audio file
Summary: Clementine crashes when playing an audio file
Keywords:
Status: CLOSED DUPLICATE of bug 1566807
Alias: None
Product: Fedora
Classification: Fedora
Component: clementine
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 15:31 UTC by Gwendal
Modified: 2018-04-17 06:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 23:53:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Gwendal 2018-04-16 15:31:23 UTC
Description of problem:


Since I upgrade from Fedora 27 to Fedora 28, Clementine crashes each time I try to play an audio file, with the following error in the terminal :

/usr/include/c++/8/bits/stl_vector.h:932: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = float; _Alloc = std::allocator<float>; std::vector<_Tp, _Alloc>::reference = float&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
[1]    29630 abort (core dumped)  clementine

I did not manage to create a bug report with ABRT (it does not succeed when retracing), but it did upload a report here: https://retrace.fedoraproject.org/faf/reports/2124585/


Version-Release number of selected component (if applicable): Clementine 1.3.1

How reproducible: Always

Steps to Reproduce:
1. Start Clementine
2. Open audio file

Actual results: Clementine crashes

Expected results: Clementine should play the file

Comment 1 Orcan Ogetbil 2018-04-16 23:53:30 UTC
Thanks for the report. This appears to be a problem with analyzers (the area between play/pause buttons and the volume slider, on the bottom). The workaround is to use no analyzers, or use the ones listed in the reference bug report. It is also reported upstream, waiting resolution.

*** This bug has been marked as a duplicate of bug 1566807 ***

Comment 2 Gwendal 2018-04-17 06:56:05 UTC
Thanks for the workaround! I was not even aware I was using an analyzer, that's why I hadn't found the duplicate.


Note You need to log in before you can comment on or make changes to this bug.