Bug 1568031 - OCP 3.10.0-0.21.0 RPMs install version 3.10.0-0.14.0 of the server
Summary: OCP 3.10.0-0.21.0 RPMs install version 3.10.0-0.14.0 of the server
Keywords:
Status: CLOSED DUPLICATE of bug 1566814
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard: aos-scalability-310
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 16:01 UTC by Mike Fiedler
Modified: 2018-04-16 19:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 19:28:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike Fiedler 2018-04-16 16:01:11 UTC
Description of problem:

The Friday, April 13 3.10.0-0.21.0 build of OCP is still based on Kubernetes 1.9.1.  The rebase landed in origin on April 9th and is needed for performance, scalability and reliability testing of OCP 3.10.

Version-Release number : 3.10.0-0.21.0


root@ip-172-31-33-11: ~ # oc version
oc v3.10.0-0.21.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-31-33-11.us-west-2.compute.internal:8443
openshift v3.10.0-0.14.0
kubernetes v1.9.1+a0ce1bc657

Comment 1 Mike Fiedler 2018-04-16 16:04:22 UTC
I missed the fact the server version in the description says 3.10.0-0.14.0.  I guess that explains the kube version.   The issue is that the 3.10.0-0.21.0 rpms install an older build of OCP.

Installed:

atomic-openshift.x86_64         3.10.0-0.21.0.git.0.a522829.el7
atomic-openshift-clients.x86_64 3.10.0-0.21.0.git.0.a522829.el7
atomic-openshift-clients-redistributable.x86_64
atomic-openshift-docker-excluder.noarch
atomic-openshift-dockerregistry.x86_64
atomic-openshift-excluder.noarch
atomic-openshift-node.x86_64    3.10.0-0.21.0.git.0.a522829.el7
atomic-openshift-pod.x86_64     3.10.0-0.21.0.git.0.a522829.el7
atomic-openshift-sdn-ovs.x86_64 3.10.0-0.21.0.git.0.a522829.el7
atomic-openshift-tests.x86_64   3.10.0-0.21.0.git.0.a522829.el7

# oc version
oc v3.10.0-0.21.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-31-33-11.us-west-2.compute.internal:8443
openshift v3.10.0-0.14.0
kubernetes v1.9.1+a0ce1bc657

Comment 2 Scott Dodson 2018-04-16 18:59:54 UTC
Fix in https://github.com/openshift/openshift-ansible/pull/7964/commits/d1861a0280b4f1dc4651fff0b55b9eb6177278a4

Before we merge that we need openshift/origin-control-plane image published to dockerhub. Coordinating w/ Clayton

Comment 3 Scott Dodson 2018-04-16 19:28:45 UTC

*** This bug has been marked as a duplicate of bug 1566814 ***


Note You need to log in before you can comment on or make changes to this bug.