Bug 156808 - flac 1.1.2-25 conflicts good version of xmms-flac
Summary: flac 1.1.2-25 conflicts good version of xmms-flac
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: flac
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 13:17 UTC by Mephisto
Modified: 2013-03-13 04:48 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-05-04 15:44:04 UTC


Attachments (Terms of Use)

Description Mephisto 2005-05-04 13:17:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
flac 1.1.2-25 wants to uninstall xmms-flac. although this is probably done to get rid of the buggy versions of 1.1.2 that caused xmms to crash, i have a 1.1.0 based xmms-flac installed, and i want to keep that...

Version-Release number of selected component (if applicable):
flac-1.1.2-25

How reproducible:
Always

Steps to Reproduce:
1. install xmms-flac < 1.1.2
2. install flac-1.1.2-25
3.
  

Actual Results:  installing flac wants to uninstall xmms-flac (1.1.0, in my case)

Expected Results:  flac should have installed without complaining about the older version of xmms-flac.

Additional info:

Comment 1 John (J5) Palmieri 2005-05-04 15:44:04 UTC
xmms is no longer in core so we no longer build xmms-flac.  Since they are from
the same sources the new xmms will want to uninstall xmms-flac.  Your best bet
is to find a maintainer for Fedora extras or become one youself.

Comment 2 Mephisto 2005-05-05 09:04:24 UTC
wth? how come xmms is no longer in core? its the most popular audio player
around! its just about the only audio player with a userfriendly GUI. and how
come flac is in core then? flac is typical 'additional functionality' in my view...

but besides that, how do i become a maintainer then? i've been building my own
apt repository for a few months now, so i dont think it should be a big problem.
but i'd probably want an apt-enabled extras mirror first, cause i prefer apt
over yum, so dont count too much on me...

but i also dont see why this cant be fixed. the spec file contains this:
Obsoletes: xmms-flac < 1.1.2-24
so changing it to
Obsoletes: xmms-flac = 1.1.2 (or "xmms-flac >= 1.1.2" if that doesnt work)
would get you rid of all bad xmms-flac packages without forcing people to
uninstall older versions.

Comment 3 John (J5) Palmieri 2005-05-05 16:00:59 UTC
I can take the obsoletes line out.  But as far as complaining about XMMS not
being in core that is not what bugzilla is for.  Flac is a library used by many
other programs, not just XMMS.  Extras is the perfect place for XMMS since it
allows the community to work on it and package it.  If it is as popular as you
say then there will be at least one person in the community who will step up to
the plate.   To become a maintainer check out
http://www.fedoraproject.org/wiki/Extras.

Comment 4 Mephisto 2005-05-05 22:19:30 UTC
sorry about the rant. it just surprised me, cause i hadn't heard about xmms
being taken out of core yet.
if it has no maintainer once fc4 comes out (and extras probably has an apt
mirror by then), i would take ownership of the package, but since i cant test it
against other stuff in extras now, i dont think thats a good idea. i dont plan
to re-install yum any time soon, nor use the official mirrors to get updates,
since they are *very* slow for me. fc4 extras really needs more (apt enabled)
mirrors... (but i suppose this isnt the place to discuss that either)


Note You need to log in before you can comment on or make changes to this bug.