Bug 1568082 - segfault in OnChannelErrorFromLink
Summary: segfault in OnChannelErrorFromLink
Keywords:
Status: CLOSED DUPLICATE of bug 1568097
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 18:04 UTC by Dr. David Alan Gilbert
Modified: 2018-04-16 18:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 18:45:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Dr. David Alan Gilbert 2018-04-16 18:04:15 UTC
Description of problem:
I've hit a ff crash that is:
 https://retrace.fedoraproject.org/faf/reports/2077858/

a couple of times now;   the graphs on that show a few hundred hits, with almost all of them being f28; so it looks like we've got a regression on our hands.
abrt refuses to report it (saying the backtrace is unusable) - although IMHO it looks fine to me.

Version-Release number of selected component (if applicable):
firefox-59.0.2-1.fc28.x86_64

How reproducible:
rarely

Steps to Reproduce:
1. Not sure;  I was watching youtube in one window and playing some h264 videos (from a CCTV camera) in the other;  but it's rare
2.
3.

Actual results:

crash 
Expected results:
Nice videos

Additional info:
Although abrt says the backtrace is unusable, this is what I've got:

#0  0x00007f9430a890d8 in mozilla::ipc::MessageChannel::OnChannelErrorFromLink() [clone .cold.747] () at /usr/lib64/firefox/libxul.so
#1  0x00007f9430fc6eb3 in mozilla::ipc::ProcessLink::OnChannelError() () at /usr/lib64/firefox/libxul.so
#2  0x00007f9430fb077a in event_process_active_single_queue.isra () at /usr/lib64/firefox/libxul.so
#3  0x00007f9430fb0d8f in event_base_loop () at /usr/lib64/firefox/libxul.so
#4  0x00007f9430f963ce in base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) () at /usr/lib64/firefox/libxul.so
#5  0x00007f9430f98849 in MessageLoop::Run() () at /usr/lib64/firefox/libxul.so
#6  0x00007f9430fa6785 in base::Thread::ThreadMain() () at /usr/lib64/firefox/libxul.so
#7  0x00007f9430f95eee in ThreadFunc(void*) () at /usr/lib64/firefox/libxul.so
#8  0x00007f9440822564 in start_thread (arg=<optimized out>) at pthread_create.c:463
        pd = <optimized out>
        now = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140274391185152, -1922445901008642846, 140727121942798, 140727121942799, 140727121942928, 140727121942928, 1907911199622257890, 1908005235980197090}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <optimized out>
#9  0x00007f943fa1431f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Comment 1 Dr. David Alan Gilbert 2018-04-16 18:45:08 UTC
persuaded abrt to file this; duping to the abrt version

*** This bug has been marked as a duplicate of bug 1568097 ***


Note You need to log in before you can comment on or make changes to this bug.