Bug 1568119 - Installation language not autodetected
Summary: Installation language not autodetected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F28FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-04-16 19:10 UTC by Alessio
Modified: 2018-04-20 17:15 UTC (History)
11 users (show)

Fixed In Version: anaconda-28.22.8-1 anaconda-28.22.8-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-20 17:15:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Alessio 2018-04-16 19:10:42 UTC
Description of problem:

In workstation live or netinst, when the installer start, the default language is English.
In previous versions of Fedora (at least F27) the local language was detected and proposed as default.
I don't know how it is detected (maybe via some IP geolocation service?), in F28 the default proposed language is always English.
Is this by design?


Version-Release number of selected component (if applicable):

Fedora 28 Branched 20180415.n.0
anaconda-28.22.7-1.fc28.x86_64


How reproducible:

"Install to hard drive" in Fedora Workstation Live. Or start a netinst iso.


Actual results:

English is always proposed as the installation language.


Expected results:

In previous versions of Fedora (tested F27) my local language is in some way autodetected and proposed for use during the installation process.

Comment 1 Alessio 2018-04-16 20:01:05 UTC
As far as I can understand, https://geoip.fedoraproject.org is contacted to get geolocation info.
Going to such URL using Firefox from the Live image, the country where I am is correctly reported.

Comment 2 Alessio 2018-04-16 20:04:49 UTC
Well, in fact, in the installation summary page, TIME & DATE is correctly set to my timezone.

Comment 3 Fedora Blocker Bugs Application 2018-04-17 12:18:10 UTC
Proposed as a Freeze Exception for 28-final by Fedora user m4rtink using the blocker tracking app because:

 Geolocation can be very useful and users expect it to work. The fix should also be very simple.

Comment 4 Radek Vykydal 2018-04-17 14:15:51 UTC
https://github.com/rhinstaller/anaconda/pull/1442

Comment 5 Adam Williamson 2018-04-17 21:42:11 UTC
The fix doesn't look *that* simple...I'm still +1 FE to this, but it'd be nice to have the build soon so we can possibly notice if anything unexpected happens in corner cases.

Comment 6 Patrick Uiterwijk 2018-04-17 22:23:56 UTC
+1 FE.

Comment 7 Mohan Boddu 2018-04-17 22:27:15 UTC
+1 FE

Comment 8 Adam Williamson 2018-04-17 22:48:49 UTC
That's +3 FE, setting accepted.

Comment 9 Fedora Update System 2018-04-19 16:12:18 UTC
anaconda-28.22.8-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7c1909bd31

Comment 10 Adam Williamson 2018-04-19 20:27:46 UTC
Tested an ISO built with that version of anaconda , confirmed that locale autodetection seems to work again (it picks English (Canada) for me now, like it used to).

Comment 11 Alessio 2018-04-19 22:36:45 UTC
(In reply to Adam Williamson from comment #10)
> Tested an ISO built with that version of anaconda , confirmed that locale
> autodetection seems to work again (it picks English (Canada) for me now,
> like it used to).

Yes, I can confirm that. It picks Italian language for me.

Comment 12 Alessio 2018-04-19 22:47:21 UTC
(In reply to Alessio from comment #11)
> (In reply to Adam Williamson from comment #10)
> > Tested an ISO built with that version of anaconda , confirmed that locale
> > autodetection seems to work again (it picks English (Canada) for me now,
> > like it used to).
> 
> Yes, I can confirm that. It picks Italian language for me.

However. Moving forward with the installation process, I'm asked to set the root password and to create a user and it should not supposed to be (avoid redundancy). Maybe I've built the Live ISO in the wrong way. Adam: what about you?

Comment 13 Adam Williamson 2018-04-19 22:56:07 UTC
I tested with a non-live ISO. Those things are only supposed to be disabled on *Workstation* live images, note...

Comment 14 Alessio 2018-04-19 23:00:05 UTC
(In reply to Adam Williamson from comment #13)
> I tested with a non-live ISO. Those things are only supposed to be disabled
> on *Workstation* live images, note...

Yes, I created a Workstation live image.

Comment 15 Fedora Update System 2018-04-20 01:49:47 UTC
anaconda-28.22.8-1.fc28, initial-setup-0.3.58-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7c1909bd31

Comment 16 Fedora Update System 2018-04-20 17:15:48 UTC
anaconda-28.22.8-1.fc28, initial-setup-0.3.58-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.