Bug 1568149 - RFC: nscd doesn't cache record containing more than one IP address.
Summary: RFC: nscd doesn't cache record containing more than one IP address.
Keywords:
Status: CLOSED DUPLICATE of bug 576801
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: glibc team
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 20:40 UTC by Paulo Andrade
Modified: 2019-08-28 06:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 15:16:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
glibc-2.12-sfdc02079051.patch (12.05 KB, text/plain)
2018-04-19 13:56 UTC, Paulo Andrade
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Sourceware 15862 0 None None None 2018-04-16 20:41:43 UTC

Description Paulo Andrade 2018-04-16 20:40:46 UTC
There is a bug report and patches at
https://sourceware.org/bugzilla/show_bug.cgi?id=15862
[nscd doesn't cache record containing more than one IP address.]

  Not specific to rhel6, as the patches are not in any upstream
version, is there some plan to implement the patches in sourceware
bugzilla?

Comment 3 Paulo Andrade 2018-04-19 13:56:25 UTC
Created attachment 1424114 [details]
glibc-2.12-sfdc02079051.patch

  It was explained that some software was doing gethostbyname on a server
with multiple ip addresses, and the proper solution would be for such
software to be adapted to use getaddrinfo (mostly based on information
at https://www.akkadia.org/drepper/userapi-ipv6.html).
  User temporarily switched to a single address in /etc/hosts for the server.
  Now the user is testing a rhel6.9 package built with the attached patch,
that is a minor adaptation of the related patches attached to the sourceware
bugzilla.

Comment 4 Florian Weimer 2018-04-24 15:16:23 UTC
As Carlos explained in bug 576801 comment 11, we did not plan to make the change in Red Hat Enterprise Linux 6 at the time, and reconsidered the change for Red Hat Enterprise Linux 7.

Adding more IP addresses visible to applications is a change which will break expectations of some users, so it is not appropriate for Red Hat Enterprise Linux 6, which is now in Maintenance Support 2.

*** This bug has been marked as a duplicate of bug 576801 ***


Note You need to log in before you can comment on or make changes to this bug.