Bug 156820 - /usr/libexec/evolution-data-server-1.2 eats cpu after login.
/usr/libexec/evolution-data-server-1.2 eats cpu after login.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-05-04 10:29 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 11:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-05-04 10:29:15 EDT
After logging in to GNOME, evo-data-server is in an endless loop...

poll([{fd=21, events=POLLIN}, {fd=23, events=POLLIN|POLLPRI}, {fd=25,
events=POLLIN}], 3, 0) = 0
poll([{fd=21, events=POLLIN}, {fd=23, events=POLLIN|POLLPRI}, {fd=25,
events=POLLIN}], 3, 0) = 0
poll([{fd=21, events=POLLIN}, {fd=23, events=POLLIN|POLLPRI}, {fd=25,
events=POLLIN}], 3, 0) = 0
poll([{fd=21, events=POLLIN}, {fd=23, events=POLLIN|POLLPRI}, {fd=25,
events=POLLIN}], 3, 0) = 0
poll([{fd=21, events=POLLIN}, {fd=23, events=POLLIN|POLLPRI}, {fd=25,
events=POLLIN}], 3, 0) = 0
Comment 1 Dave Malcolm 2005-05-04 10:34:28 EDT
What addressbooks and calendars are enabled?  Can you isolate the problem by
selectively toggling them on/off?
Comment 2 David Woodhouse 2005-05-05 08:01:24 EDT
Turning the Fedora calendar off might have fixed it.

I then turned the Fedora calendar back on again, and tried logging in to GNOME
twice more; once with network and once without. Still the problem didn't recur.
It's been happening repeatedly recently. Will keep an eye out for it.
Comment 3 Dave Malcolm 2005-05-05 15:54:04 EDT
Evolution keeps local cached data for web calendars.  Maybe you're not seeing
the problem because Evolution's now got it in its cache?

You might want to try shutting down evolution and e-d-s, and then deleting:
~/.evolution/cache/calendar/webcal___fedora.redhat.com_participate_schedule_fedora-project.ics/cache.xml
(or similar)

and see if you can get the problem to recur again.
Comment 4 David Woodhouse 2005-05-13 15:20:17 EDT
It just happened again.

(gdb) t a a bt

Thread 3 (Thread 809305312 (LWP 3013)):
#0  0x0ff43d0c in poll () from /lib/libc.so.6
#1  0x0f7c4a48 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#2  0x0f7c5004 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#3  0x0e926aa4 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
#4  0x0f7e57f0 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
#5  0x0fc65878 in start_thread () from /lib/libpthread.so.0
#6  0x0ff43cf4 in poll () from /lib/libc.so.6
#7  0x00000000 in ?? ()

Thread 2 (Thread 851252448 (LWP 3025)):
#0  0x0ff43d0c in poll () from /lib/libc.so.6
#1  0x0f7c4a48 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#2  0x0f7c5004 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#3  0x008fcdb8 in e_book_set_default_source () from /usr/lib/libebook-1.2.so.3
#4  0x0fc65878 in start_thread () from /lib/libpthread.so.0
#5  0x0ff43cf4 in poll () from /lib/libc.so.6
#6  0x00000000 in ?? ()

Thread 1 (Thread 805491808 (LWP 2965)):
#0  0x0fc67b84 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x0f7c3fd8 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#2  0x0f7c4810 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0x0f7c5004 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4  0x0e886414 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#5  0x0f7c3fd8 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0x00000000 in ?? ()
Comment 5 Dave Malcolm 2005-06-29 23:40:13 EDT
Is this still happening?
Comment 6 David Woodhouse 2005-06-30 06:15:37 EDT
Haven't seen it recently.
Comment 8 Matthew Barnes 2006-07-31 10:50:45 EDT
David, this bug has been languishing here for quite awhile.

Are you still seeing this behavior with the latest FC5 or Rawhide releases?
Comment 9 David Woodhouse 2006-07-31 11:01:38 EDT
Haven't seen it recently. Might as well close it until/unless it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.