Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1568222 - Bluetooth on iphone does not mount or allow file transfer to host laptop.
Summary: Bluetooth on iphone does not mount or allow file transfer to host laptop.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 01:56 UTC by Paul Lambert
Modified: 2018-05-02 08:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 08:27:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Lambert 2018-04-17 01:56:42 UTC
Description of problem:
Though the bluetooth settings window shows that an iphone is paired and the connection is on, the send files button does not appear and the iphone documents and photo directories are not mounted

Version-Release number of selected component (if applicable):
4.15.15-300.fc27.x86_64
bluez-libs-devel.i686                   5.49-1.fc27                     updates 
bluez-libs-devel.x86_64                 5.49-1.fc27                     updates 
kf5-bluez-qt.i686                       5.44.0-1.fc27                   updates 
kf5-bluez-qt.x86_64                     5.44.0-1.fc27                   updates 
kf5-bluez-qt-devel.i686                 5.44.0-1.fc27                   updates 
kf5-bluez-qt-devel.x86_64               5.44.0-1.fc27                   updates 


How reproducible:
Every time

Steps to Reproduce:
1. Turn laptop bluetooth on
2. Turn iphone bluetooth on
3. Pair devices

Actual results:
This bug is a continuation of the closed bug 1389347

The instructions to start the dbus related services were vague. Neither were specified as to which user these apps should be started under.  Later in the comments it was stated the global related service should be started as root but no order which gets started first.

systemctl --user enable obex
systemctl --global enable obex

Expected results:
Since bluetooth emulates a physical wire from a removable device to the laptop the user should get the same  results as if the iphone is connected by a USB cable.  Both the Documents and photo directories should automatically mount using bluetooth.

Additional info:

Comment 1 Bastien Nocera 2018-04-17 08:10:16 UTC
(In reply to Paul Lambert from comment #0)
> Description of problem:
> Though the bluetooth settings window shows that an iphone is paired and the
> connection is on, the send files button does not appear

There's no ObexFTP or ObexPush support on iOS devices.

> and the iphone
> documents and photo directories are not mounted

Completely unrelated to Bluetooth (and impossible with a wire, as things stand).

> Version-Release number of selected component (if applicable):
> 4.15.15-300.fc27.x86_64
> bluez-libs-devel.i686                   5.49-1.fc27                    
> updates 
> bluez-libs-devel.x86_64                 5.49-1.fc27                    
> updates 
> kf5-bluez-qt.i686                       5.44.0-1.fc27                  
> updates 
> kf5-bluez-qt.x86_64                     5.44.0-1.fc27                  
> updates 
> kf5-bluez-qt-devel.i686                 5.44.0-1.fc27                  
> updates 
> kf5-bluez-qt-devel.x86_64               5.44.0-1.fc27                  
> updates 

Do you even use GNOME?

> Expected results:
> Since bluetooth emulates a physical wire from a removable device to the
> laptop the user should get the same  results as if the iphone is connected
> by a USB cable.  Both the Documents and photo directories should
> automatically mount using bluetooth.

Wishful thinking though. That's not the case.

Comment 2 Paul Lambert 2018-05-01 03:59:41 UTC
I use gnome desktop. When I connect iPhone up by usb the apps folders mount and the iPhone pictures mount. The pictures can easily be copied to host. 

There are several iPhone apps that will copy files to and from iPhone over WiFi to a Fedora host. And even sync them.  This indicates that some form of ftp exists.  If so then using Bluetooth over sockets should also work just Apple mirroring will work over both WiFi and Bluetooth.  There is one iPhone app that claims to support both WiFi and bluetooth file transfers.  Since it is a purchased app I am attempting to confirm that this is possible before purchasing.

Comment 3 Bastien Nocera 2018-05-02 08:27:08 UTC
Sorry, but I have no idea if a specific, non-standard iOS application will work as expected.

I doubt they would be able to replicate the access given when a USB cable is plugged in, given the fact that applications on the phone aren't able to access anything but their own files.

I think you're better off testing it yourself, or asking on a user forum, as this isn't related to gnome-bluetooth.


Note You need to log in before you can comment on or make changes to this bug.