Bug 1568245 - [APB] apb prepare --include-dependencies return exception
Summary: [APB] apb prepare --include-dependencies return exception
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Dylan Murray
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 03:32 UTC by sunzhaohua
Modified: 2018-07-30 19:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
We deprecated --include-deps flag from `apb prepare`.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:21 UTC

Description sunzhaohua 2018-04-17 03:32:08 UTC
Description of problem:
Inside the APB directory, run `apb prepare --include-dependencies` return exception.

Version-Release number of selected component (if applicable):
openshift:3.10
apb: 1.2.1

How reproducible:
Always

Steps to Reproduce:
1. make a apb or clone from github ansibleplaybookbundle/hello-world-apb
2. Inside the apb derectory, run `apb prepare --include-dependencies`


Actual results:
# apb prepare --include-dependencies
Trying to guess list of dependencies for APB
Exception occurred! 'print $3'

Expected results:
apb prepare --include-dependencies works successfully.

Additional info:

Comment 1 Dylan Murray 2018-04-26 20:06:58 UTC
https://github.com/ansibleplaybookbundle/ansible-playbook-bundle/pull/273

The include-dep work is extremely buggy and never took off the ground. We will deprecate this so that a user cannot run into the similar exception.

Comment 2 David Zager 2018-04-27 23:39:55 UTC
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=679545

brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/apb-tools:v3.10.0-0.16.0.4

Comment 3 sunzhaohua 2018-04-28 06:11:18 UTC
Verified with latest image in brew. 
Will wait for the rpm ready to double verify.

--include-dependencies option has been removed.
# apb prepare -h
groupadd: GID '0' already exists
usermod: group 'apb' does not exist
usage: apb prepare [-h] [--provider {openshift,kubernetes}]
                   [--dockerfile DOCKERFILE]

optional arguments:
  -h, --help            show this help message and exit
  --provider {openshift,kubernetes}
                        Targeted cluster type
  --dockerfile DOCKERFILE, -f DOCKERFILE
                        Name of Dockerfile to build with

# apb prepare --include-dependencies
groupadd: GID '0' already exists
usermod: group 'apb' does not exist
usage: apb [-h] [--debug] [--project BASE_PATH]
           
           {relist,run,help,test,refresh,prepare,setup,bootstrap,list,remove,init,version,build,push,serviceinstance}
           ...
apb: error: unrecognized arguments: --include-dependencies

Comment 4 sunzhaohua 2018-05-03 03:37:30 UTC
Verified 
# apb version
Version: apb-1.2.5

# apb prepare -h
usage: apb prepare [-h] [--provider {openshift,kubernetes}]
                   [--dockerfile DOCKERFILE]

optional arguments:
  -h, --help            show this help message and exit
  --provider {openshift,kubernetes}
                        Targeted cluster type
  --dockerfile DOCKERFILE, -f DOCKERFILE
                        Name of Dockerfile to build with

# apb init my-01-apb
Initializing /root/my-01-apb for an APB.
Generating playbook files
Successfully initialized project directory at: /root/my-01-apb
Please run *apb prepare* inside of this directory after editing files.

# cd my-01-apb/
# apb prepare --include-dependencies
usage: apb [-h] [--debug] [--project BASE_PATH]         
           {relist,run,help,test,refresh,prepare,setup,bootstrap,list,remove,init,version,build,push,serviceinstance}
           ...
apb: error: unrecognized arguments: --include-dependencies

Comment 6 errata-xmlrpc 2018-07-30 19:13:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.