Bug 1568251 - An error message 'invalid log level' is seen in heketi log during heketi startup
Summary: An error message 'invalid log level' is seen in heketi log during heketi startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: John Mulligan
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1568861
TreeView+ depends on / blocked
 
Reported: 2018-04-17 04:02 UTC by krishnaram Karthick
Modified: 2018-12-18 07:25 UTC (History)
9 users (show)

Fixed In Version: heketi-6.0.0-14.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, Heketi configuration files that lacked a specific log level which caused the application to display a meaningless log message on startup. With this fix, Heketi ignores the lack of an explicit log level in the configuration file.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:14 UTC

Description krishnaram Karthick 2018-04-17 04:02:06 UTC
Description of problem:
The following error message is seen in heketi log when heketi is started.

[heketi] ERROR 2018/04/16 14:34:34 /src/github.com/heketi/heketi/apps/glusterfs/app.go:100: invalid log level: 

heketi log:

Heketi 6.0.0
[heketi] INFO 2018/04/16 14:34:34 Loaded kubernetes executor
[heketi] ERROR 2018/04/16 14:34:34 /src/github.com/heketi/heketi/apps/glusterfs/app.go:100: invalid log level: 
[heketi] INFO 2018/04/16 14:34:34 Block: Auto Create Block Hosting Volume set to true
[heketi] INFO 2018/04/16 14:34:34 Block: New Block Hosting Volume size 100 GB
[heketi] INFO 2018/04/16 14:34:34 GlusterFS Application Loaded
[heketi] INFO 2018/04/16 14:34:34 Started Node Health Cache Monitor
Listening on port 8080

I'm not sure if this error message is significant, I can see all the usual logs being logged in heketi

Version-Release number of selected component (if applicable):
rhgs-volmanager-container-3.3.1-8.4

How reproducible:
always

Steps to Reproduce:
1. create a heketi container and check heketi logs

Actual results:
An error message on log level is seen

Expected results:
if the message doesn't make any significance, this error should be logged 

Additional info:

Comment 2 Michael Adam 2018-04-25 12:58:42 UTC
We should fix this for 3.10.

Comment 7 Rachael 2018-06-05 10:42:44 UTC
The heketi logs were searched for the error message mentioned in the bug, nos uch messages were found.

[root@dhcp46-144 ~]# oc logs heketi-storage-1-56lwl |grep "invalid log level"
[root@dhcp46-144 ~]# 

Verified on 2 different setups.

Version-Release number of selected component:
rhgs3/rhgs-volmanager-rhel7:3.3.1-15

Hence moving it to verified.

Comment 8 Anjana KD 2018-08-31 00:42:26 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 10 Anjana KD 2018-09-05 09:34:12 UTC
Have updated the doc text based on the feed back given.

Comment 11 John Mulligan 2018-09-05 19:26:39 UTC
(In reply to Anjana from comment #10)
> Have updated the doc text based on the feed back given.

Looks OK to me.

Comment 13 errata-xmlrpc 2018-09-12 09:22:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.