Bug 1568274 - Lilypond Crash while Drawing Systems
Summary: Lilypond Crash while Drawing Systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lilypond
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/p/testlilyiss...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 06:13 UTC by Onyeibo Oku
Modified: 2018-06-01 08:32 UTC (History)
7 users (show)

Fixed In Version: lilypond-2.19.81-5.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 12:48:53 UTC
Type: Bug


Attachments (Terms of Use)
test file (3.01 KB, text/plain)
2018-04-17 06:13 UTC, Onyeibo Oku
no flags Details
gdb backtrace log for this issue (15.16 KB, text/plain)
2018-05-08 14:15 UTC, Mamoru TASAKA
no flags Details
suggestion patch (1.88 KB, patch)
2018-05-08 15:01 UTC, Mamoru TASAKA
no flags Details | Diff

Description Onyeibo Oku 2018-04-17 06:13:45 UTC
Created attachment 1422912 [details]
test file

Description of problem:
Lilpond successful parses, interprets and exports music to MIDI but crashes while drawing systems

Version-Release number of selected component (if applicable):
2.19.81-4.fc29

How reproducible:
It is constant ... repeats (always happening)


Steps to Reproduce:
1. run lilypond against the attached file (as-the-deer.ly) on the terminal and watch the output
2. That's it

Actual results:
/usr/include/c++/8/bits/stl_vector.h:932: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = Beam_stem_segment; _Alloc = std::allocator<Beam_stem_segment>; std::vector<_Tp, _Alloc>::reference = Beam_stem_segment&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
Aborted (core dumped)

Expected results:
(1) Layout output
(2) Export to PDF
(3) Success: compilation successfully completed

Additional info:

Comment 1 Gwyn Ciesla 2018-04-19 13:52:00 UTC
Sent to bug-lilypond@gnu.org:

Hi! Gwyn Ciesla, Fedora lilypond maintainer.

First, we have a crash I'm having trouble debugging: https://bugzilla.redhat.com/show_bug.cgi?id=1568274

Second, I can't build lilypond on Fedora 28 or newer. It fails with a Python warning:

ERROR: Please install required programs:  Python.h (python-devel, python-dev or libpython-dev package)

I suspect that this is related to the python-devel package becoming python2-devel, but all the required headers are still there.

Let me know if I can provide any additional information.

Thank you!

-Gwyn

she/her/hers

Comment 2 Hendrik Borghorst 2018-04-22 18:04:35 UTC
Kodi 17.6 built with Fedora 28 crashes with an identical failure:

$ kodi
/usr/include/c++/8/bits/stl_vector.h:932: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = SVertex; _Alloc = std::allocator<SVertex>; std::vector<_Tp, _Alloc>::reference = SVertex&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
/usr/bin/kodi: Zeile 175: 103634 Abgebrochen             (Speicherabzug geschrieben) "$LIBDIR/${bin_name}/${bin_name}.bin" $SAVED_ARGS
Crash report available at /home/hendrik/kodi_crashlog-20180422_200042.log

Comment 3 Hendrik Borghorst 2018-04-22 18:33:41 UTC
Sorry for hijacking this. It was an out of bounds error in Kodi.

Comment 4 Mamoru TASAKA 2018-05-08 14:15:53 UTC
Created attachment 1433235 [details]
gdb backtrace log for this issue

Comment 5 Mamoru TASAKA 2018-05-08 14:16:48 UTC
Would you check if the following works?
https://koji.fedoraproject.org/koji/taskinfo?taskID=26849104

Comment 6 Mamoru TASAKA 2018-05-08 14:29:42 UTC
For F-29: https://koji.fedoraproject.org/koji/taskinfo?taskID=26849748

Comment 7 Gwyn Ciesla 2018-05-08 14:42:34 UTC
Works for me on f28. Are you willing/able to commit and build?

Comment 8 Mamoru TASAKA 2018-05-08 15:01:36 UTC
Created attachment 1433256 [details]
suggestion patch

If you are okay, I can commit. Or you can apply my suggestion patch (now attached).

Comment 9 Mamoru TASAKA 2018-05-08 15:04:06 UTC
(By the way, I am going to bed now)

Comment 10 Gwyn Ciesla 2018-05-08 15:14:39 UTC
I'll let you do it at your convenience. Thank you!

Comment 11 Mamoru TASAKA 2018-05-09 07:54:04 UTC
Okay, I will push updates later. Later I will try to send this to the mailing list after registering myself into the mailing list... (I cannot register issue to sourceforge tracker...)

Comment 12 Fedora Update System 2018-05-09 09:52:30 UTC
lilypond-2.19.81-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-088d37c702

Comment 13 Fedora Update System 2018-05-10 01:30:38 UTC
lilypond-2.19.81-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-088d37c702

Comment 14 Fedora Update System 2018-05-17 12:48:53 UTC
lilypond-2.19.81-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.