Bug 1568276 - rt_cmos registration error.
Summary: rt_cmos registration error.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1594551 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 06:21 UTC by edpil02
Modified: 2018-07-11 16:16 UTC (History)
41 users (show)

Fixed In Version: kernel-4.17.3-100.fc27 kernel-4.17.3-200.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-01 01:33:48 UTC
Type: Bug


Attachments (Terms of Use)

Description edpil02 2018-04-17 06:21:53 UTC
Got rt_cmos errors with the latest kernel-4.17 versions.
Remember to have no issues with the first versions (rc0.git1.1.fc29 ..)

dmesg | grep nvmem
[    0.709024] rtc_cmos 00:05: nvmem registration failed


Msi z370 pc pro motherboard.

Comment 1 Timur Kristóf 2018-05-27 13:56:56 UTC
This also happened to my machine using the latest rawhide kernel. Asked on the linux-rtc mailing list, this is already solved upstream.

Discussion:
https://marc.info/?t=152724036300005&r=1&w=2

The solution is to just use this patch:
https://git.kernel.org/pub/scm/linux/kernel/git/abelloni/linux.git/commit/?h=rtc-next&id=c59b3715ac16544f8f68ab7af03f108e339b36aa

Comment 2 edpil02 2018-05-28 06:27:21 UTC
Thanks for your reply.

Comment 3 You 2018-06-03 14:29:31 UTC
Has that fixed it into latest rawhide kernel?

I am still getting the error with the latest rawhide kernel (no-debug repo on Fedora 28).

rtc_cmos 00:02: nvmem registration failed
+pnp:00:02

and the system fails to boot

kernel version 4.17.0-0.rc7.git2.2.fc29

Comment 4 edpil02 2018-06-03 19:32:29 UTC
(In reply to You from comment #3)
> Has that fixed it into latest rawhide kernel?
> 
> I am still getting the error with the latest rawhide kernel (no-debug repo
> on Fedora 28).
> 
> rtc_cmos 00:02: nvmem registration failed
> +pnp:00:02
> 
> and the system fails to boot
> 
> kernel version 4.17.0-0.rc7.git2.2.fc29


Same issue :

4.17.0-0.rc7.git1.2.fc29.x86_64
[    0.652128] rtc_cmos 00:05: nvmem registration failed

But no boot problem ,system run smooth.

Comment 5 nanericwang 2018-06-18 01:53:48 UTC
Same issue on my laptop and my server.

Comment 6 Gerald Cox 2018-06-20 07:07:55 UTC
Still occurs on kernel-4.17.2-200.fc28

Comment 7 nanericwang 2018-06-20 07:14:07 UTC
Root cause is found:
You have to enable CONFIG_RTC_NVMEM in kernel.

More details:
https://cateee.net/lkddb/web-lkddb/RTC_NVMEM.html

Comment 8 Gerald Cox 2018-06-20 07:39:58 UTC
(In reply to nanericwang from comment #7)
> Root cause is found:
> You have to enable CONFIG_RTC_NVMEM in kernel.
> 
> More details:
> https://cateee.net/lkddb/web-lkddb/RTC_NVMEM.html

You would only enable it if you had the necessary hardware to support it.  The correct resolution is to have the patch applied (and hopefully it will be soon) that is mentioned in comment #1.

This is now the forth instance I've encountered where spurious messages are being generated because optional (or hardware related to a specific processor such as Intel) isn't present (i.e. you are using AMD).  

This is just causing people to waste time searching for error messages that aren't errors.  It needs to stop.

Comment 9 Christian Labisch 2018-06-24 10:13:37 UTC
I experience the same issue on a SCHENKER XMG, CLEVO barebone based notebook.
Message rtc_cmos 00:02: nvmem registration failed | Kernel Device +pnp:00:02

Comment 10 Geoff Goas 2018-06-24 14:07:28 UTC
Getting this message on my Lenovo 520s with 4.17.2-200.fc28.x86_64.

Comment 11 istaff 2018-06-24 16:15:51 UTC
Have the same message in my old notebook asus x71sl, kernel 4.17.2-200.fc28.x86_64
Can't boot since last kernel update.

Comment 12 mike santiago 2018-06-24 17:22:17 UTC
Lenovo T420 with 4.17.2-200.fc28.x86_64. rtc_cmos 00:05: nvmem registration failed but the system boots and appears to operate accordingly.

Comment 13 Mustafa Mehmed 2018-06-25 04:13:02 UTC
Product B350M MORTAR ARCTIC (MS-7A37) motherboard
CPU: AMD Ryzen 7 1700 Eight-Core Processor

4.17.2-200.fc28.x86_64

System boots OK and appears to work normally.

Comment 14 Julian Sikorski 2018-06-25 05:35:41 UTC
Happens to me on 4.17.2-200.fc28.x86_64 and Schenker XMG p501.

Comment 15 Robert Mader 2018-06-25 09:42:53 UTC
Same here, 4.17.2-200.fc28.x86_64, Thinkpad x230

Apart from the message, everything works fine

Comment 16 Kyriakos Fytrakis 2018-06-25 11:28:18 UTC
Same here, 4.17.2-200.fc28.x86_64, HP Spectre x360 (Skylake)

Apart from the message, everything works.

Comment 17 samoht0 2018-06-25 11:43:16 UTC
rtc_cmos 00:01: nvmem registration failed
on 4.17.2-200.fc28.x86_64, old HP 635 with AMD E-450 APU (Bobcat)
Apart from the message, no problems spotted.

Comment 18 Jeremy Cline 2018-06-25 15:21:03 UTC
Hi folks. The fix for this should be included in the v4.17.3 builds, which should be up for testing tomorrow or Wednesday.

Comment 19 Jeremy Cline 2018-06-25 15:22:30 UTC
*** Bug 1594551 has been marked as a duplicate of this bug. ***

Comment 20 Michael Erwin 2018-06-25 15:30:29 UTC
Thanks Jeremy for the update!

FYI:

Lenovo T430
rtc_cmos 00:02: nvmem registration failed

kernel-4.17.2-200.fc28

sudo dmidecode -t bios -q

BIOS Version: G1ETB6WW (2.76 )
Release Date: 03/22/2018
BIOS Revision: 2.76
Firmware Revision: 1.13


No other issues observed. Waiting on the fix for v4.17.3  (Comment 1 & 18)

Comment 21 Christian Labisch 2018-06-25 15:34:30 UTC
That's great news ... thank you for the information, Jeremy ! :)
Besides this minor issue kernel 4.17.2 works as expected so far.

Comment 22 istaff 2018-06-26 07:25:40 UTC
Thank you. Hope it will fix the problem because I have the problem in my dell desktop optiplex.....

Comment 23 nanericwang 2018-06-26 09:10:29 UTC
(In reply to Jeremy Cline from comment #18)
> Hi folks. The fix for this should be included in the v4.17.3 builds, which
> should be up for testing tomorrow or Wednesday.

Which commit? I didn't see it in https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.3

Comment 24 Fedora Update System 2018-06-26 19:26:34 UTC
kernel-4.17.3-100.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2a0f8b2c9d

Comment 25 Fedora Update System 2018-06-26 19:28:28 UTC
kernel-4.17.3-200.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d92fde52d7

Comment 26 Fedora Update System 2018-06-28 12:30:53 UTC
kernel-4.17.3-100.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2a0f8b2c9d

Comment 27 Fedora Update System 2018-06-28 15:02:57 UTC
kernel-4.17.3-200.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d92fde52d7

Comment 28 Fedora Update System 2018-07-01 01:33:48 UTC
kernel-4.17.3-100.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2018-07-01 02:37:23 UTC
kernel-4.17.3-200.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Mustafa Mehmed 2018-07-01 22:53:23 UTC
kernel-4.17.3-200.fc28 has fixed this problem on
B350M MORTAR ARCTIC (MS-7A37) motherboard
CPU: AMD Ryzen 7 1700 Eight-Core Processor

Thank you.

Comment 31 istaff 2018-07-06 09:11:38 UTC
I'm still having problem to boot fedora , have updated kernel to 4.17.3-200.fc28 
on my  desktop pc optiplex 780 the error message has disappeared but it's blocking at logo "f" fedora, and in my asus x71sl it's ok, I can boot now.

Comment 32 Michael Erwin 2018-07-11 16:16:43 UTC
Confirmed Fixed with kernel-4.17.3-200.fc28

Also confirmed fix still works with the new Spectre, Meltdown, TLBleed BIOS/FW updates for T430 & W530

Lenovo ThinkPad T430 BIOS G1ETB7WW (2.77 ) 06/05/2018
Lenovo ThinkPad W430 BIOS G5ETB2WW (2.72 ) 06/11/2018


Note You need to log in before you can comment on or make changes to this bug.