Bug 1568281 - SELinux is preventing chronyc from 'write' accesses on the directory chrony.
Summary: SELinux is preventing chronyc from 'write' accesses on the directory chrony.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 06:48 UTC by mezhang
Modified: 2018-10-30 10:04 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.13.1-197.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:03:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:04:01 UTC

Description mezhang 2018-04-17 06:48:48 UTC
Description of problem:

SELinux is preventing chronyc from 'write' accesses on the directory chrony.

Version-Release number of selected component (if applicable):

selinux-policy-3.13.1-166.el7_4.9.noarch
chrony-3.1-2.el7.x86_64

How reproducible:

when chrony logrotate /var/log/audit/audit.log output these messages.

~~~
# ausearch -i -m avc
----
type=PROCTITLE msg=audit(2018年04月08日 03:22:01.353:1979) : proctitle=/usr/bin/chronyc cyclelogs
type=SYSCALL msg=audit(2018年04月08日 03:22:01.353:1979) : arch=x86_64 syscall=bind success=no exit=EACCES(許可がありません) a0=0x3 a1=0x7ffc2dd7c900 a2=0x6e a3=0x0 items=0 ppid=18120 pid=18121 auid=root uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=261 comm=chronyc exe=/usr/bin/chronyc subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)


type=AVC msg=audit(2018年04月08日 03:22:01.353:1979) : avc:  denied  { write } for  pid=18121 comm=chronyc name=chrony dev="tmpfs" ino=13111 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:chronyd_var_run_t:s0 tclass=dir
~~~

Expected results:

Why output the denied {write} messages.

Additional info:

I found the Related bug ticket in Fedora.
https://bugzilla.redhat.com/show_bug.cgi?id=1436012

Comment 3 Milos Malik 2018-04-17 09:22:18 UTC
Does comment#2 really belong to this bug? This bug is about chronyc executed from logrotate.

Comment 4 Lukas Vrabec 2018-04-17 10:32:53 UTC
heh, sure, wrong window. Sorry.

Comment 5 Lukas Vrabec 2018-04-17 10:33:27 UTC
commit 78ec684c65b786da0b52bf9d41dfd5768fc173f6
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Tue Dec 12 12:33:01 2017 +0100

    Allow domain transition from logrotate_t to chronyc_t BZ(1436013)

Comment 9 errata-xmlrpc 2018-10-30 10:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.