Bug 1568304 - Automate Methods from Dynamic Dialog are being Run More than Designed / Expected
Summary: Automate Methods from Dynamic Dialog are being Run More than Designed / Expected
Keywords:
Status: CLOSED DUPLICATE of bug 1571000
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.3
Assignee: eclarizi
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 08:15 UTC by Cyril Coupel
Modified: 2018-04-27 13:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 21:53:07 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Cyril Coupel 2018-04-17 08:15:12 UTC
Description of problem:
methods of dynamic elements of dialogs are run too many times

Version-Release number of selected component (if applicable):
5.9.0 and 5.9.1

How reproducible:
all dynamics dialog

Steps to Reproduce:
1. create a method with the code below:
widget=$evm.root["object_name"]
value=$evm.root["value"]
$evm.log(:info,"CC- #{widget} value=#{value}")
root_other="dialog_text_box"
other="#{root_other}_1"
  $evm.log(:info,"    CC- widget-#{other} value=#{$evm.root[other]}")
other="#{root_other}_2"
  $evm.log(:info,"    CC- widget-#{other} value=#{$evm.root[other]}")
other="#{root_other}_3"
  $evm.log(:info,"    CC- widget-#{other} value=#{$evm.root[other]}")
2. create 3 instances that execute the previous method
3. create a dialog with 3 dynamic text box based on each instance
4. set field 1 to refresh field 2 and set field 2 to refresh field 3
5. create a generic catalog item with this dialog
6. order a service for the previous catalog item
7. look at the automation log: the method runs 6 times

8. change the content of the field 2
9. look at the automation log: the method runs 4 times

10. change the content of the field 1
11. look at the automation log: the method runs 8 times

Actual results:
for each field to refresh, all dynamics fialog element method are run

Expected results:
only the expected refreshed fields runs its method

Additional info:
log extract:

Dialog init
[----] I, [2018-04-17T09:10:05.760192 #13604:a92dec]  INFO -- : <AEMethod widget_1> CC- widget_1 value=
[----] I, [2018-04-17T09:10:05.765725 #13604:a92dec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:10:05.771273 #13604:a92dec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:05.783054 #13604:a92dec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:06.744492 #13604:b459ec]  INFO -- : <AEMethod widget_1> CC- widget_2 value=
[----] I, [2018-04-17T09:10:06.753854 #13604:b459ec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:10:05 +0200
[----] I, [2018-04-17T09:10:06.757234 #13604:b459ec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:06.761359 #13604:b459ec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:07.914763 #13604:2cb0514]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:10:07.917365 #13604:2cb0514]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:10:05 +0200
[----] I, [2018-04-17T09:10:07.919874 #13604:2cb0514]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=2018-04-17 09:10:06 +0200
[----] I, [2018-04-17T09:10:07.921783 #13604:2cb0514]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:08.961164 #13604:3f671d0]  INFO -- : <AEMethod widget_1> CC- widget_1 value=
[----] I, [2018-04-17T09:10:08.964759 #13604:3f671d0]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:10:08.968709 #13604:3f671d0]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:08.975248 #13604:3f671d0]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:10.291874 #13604:4f89f68]  INFO -- : <AEMethod widget_1> CC- widget_2 value=
[----] I, [2018-04-17T09:10:10.297710 #13604:4f89f68]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:10:10.304662 #13604:4f89f68]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:10.310759 #13604:4f89f68]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:11.569536 #13604:a92dec]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:10:11.573274 #13604:a92dec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:10:11.578916 #13604:a92dec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:11.582856 #13604:a92dec]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=


update widget 2
[----] I, [2018-04-17T09:10:51.132289 #13604:47169bc]  INFO -- : <AEMethod widget_1> CC- widget_1 value=
[----] I, [2018-04-17T09:10:51.145041 #13604:47169bc]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:10:51.152824 #13604:47169bc]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:51.158180 #13604:47169bc]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:52.246456 #13604:5335e50]  INFO -- : <AEMethod widget_1> CC- widget_2 value=
[----] I, [2018-04-17T09:10:52.273630 #13604:5335e50]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:10:51 +0200
[----] I, [2018-04-17T09:10:52.283025 #13604:5335e50]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:10:52.291553 #13604:5335e50]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:53.616561 #13604:a92d24]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:10:53.618178 #13604:a92d24]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:10:51 +0200
[----] I, [2018-04-17T09:10:53.624124 #13604:a92d24]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=2018-04-17 09:10:52 +0200
[----] I, [2018-04-17T09:10:53.627056 #13604:a92d24]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:10:54.650579 #13604:c6a1c4]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:10:54.654379 #13604:c6a1c4]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:10:08 +0200
[----] I, [2018-04-17T09:10:54.661235 #13604:c6a1c4]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=aa
[----] I, [2018-04-17T09:10:54.671452 #13604:c6a1c4]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=2018-04-17 09:10:11 +0200

update widget 1
[----] I, [2018-04-17T09:12:13.294692 #13604:3eb1614]  INFO -- : <AEMethod widget_1> CC- widget_1 value=
[----] I, [2018-04-17T09:12:13.297822 #13604:3eb1614]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:12:13.300275 #13604:3eb1614]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:12:13.303239 #13604:3eb1614]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:12:14.220271 #13604:452ed20]  INFO -- : <AEMethod widget_1> CC- widget_2 value=
[----] I, [2018-04-17T09:12:14.224760 #13604:452ed20]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:12:13 +0200
[----] I, [2018-04-17T09:12:14.230146 #13604:452ed20]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:12:14.235101 #13604:452ed20]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:12:15.357470 #13604:5135e20]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:12:15.367064 #13604:5135e20]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:12:13 +0200
[----] I, [2018-04-17T09:12:15.373478 #13604:5135e20]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=2018-04-17 09:12:14 +0200
[----] I, [2018-04-17T09:12:15.377955 #13604:5135e20]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:12:16.560413 #13604:a9db98]  INFO -- : <AEMethod widget_1> CC- widget_2 value=
[----] I, [2018-04-17T09:12:16.567689 #13604:a9db98]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=a
[----] I, [2018-04-17T09:12:16.574212 #13604:a9db98]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=aa
[----] I, [2018-04-17T09:12:16.576926 #13604:a9db98]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=2018-04-17 09:10:54 +0200
[----] I, [2018-04-17T09:12:17.654998 #13604:eec550]  INFO -- : <AEMethod widget_1> CC- widget_1 value=
[----] I, [2018-04-17T09:12:17.664431 #13604:eec550]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=
[----] I, [2018-04-17T09:12:17.670266 #13604:eec550]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:12:17.675137 #13604:eec550]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:12:18.806545 #13604:3f25154]  INFO -- : <AEMethod widget_1> CC- widget_2 value=
[----] I, [2018-04-17T09:12:18.817471 #13604:3f25154]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:12:17 +0200
[----] I, [2018-04-17T09:12:18.819560 #13604:3f25154]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=
[----] I, [2018-04-17T09:12:18.821422 #13604:3f25154]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:12:19.969485 #13604:4769644]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:12:19.972458 #13604:4769644]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=2018-04-17 09:12:17 +0200
[----] I, [2018-04-17T09:12:19.975953 #13604:4769644]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=2018-04-17 09:12:18 +0200
[----] I, [2018-04-17T09:12:19.977926 #13604:4769644]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=
[----] I, [2018-04-17T09:12:21.231836 #13604:aa0974]  INFO -- : <AEMethod widget_1> CC- widget_3 value=
[----] I, [2018-04-17T09:12:21.235036 #13604:aa0974]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_1 value=a
[----] I, [2018-04-17T09:12:21.239169 #13604:aa0974]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_2 value=2018-04-17 09:12:16 +0200
[----] I, [2018-04-17T09:12:21.256510 #13604:aa0974]  INFO -- : <AEMethod widget_1>     CC- widget-dialog_text_box_3 value=2018-04-17 09:10:54 +0200

Comment 2 Tina Fitzgerald 2018-04-26 21:53:07 UTC

*** This bug has been marked as a duplicate of bug 1571000 ***


Note You need to log in before you can comment on or make changes to this bug.