Bug 1568305 - empty vNIC profiles tab in edit Network dialog
Summary: empty vNIC profiles tab in edit Network dialog
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 08:17 UTC by Lucie Leistnerova
Modified: 2018-06-26 08:44 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:44:58 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: blocker-
ylavi: exception+
ylavi: testing_plan_complete?


Attachments (Terms of Use)
edit network dialog (55.57 KB, image/png)
2018-04-17 08:17 UTC, Lucie Leistnerova
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90494 0 'None' 'MERGED' 'webadmin: Fix AddRemoveRowWidget visibility state' 2019-12-06 07:06:55 UTC
oVirt gerrit 90495 0 'None' 'MERGED' 'webadmin: Fix empty vNIC profiles tab' 2019-12-06 07:06:56 UTC
oVirt gerrit 90627 0 'None' 'MERGED' 'webadmin: Fix AddRemoveRowWidget visibility state' 2019-12-06 07:06:54 UTC
oVirt gerrit 90628 0 'None' 'MERGED' 'webadmin: Fix empty vNIC profiles tab' 2019-12-06 07:06:56 UTC

Description Lucie Leistnerova 2018-04-17 08:17:19 UTC
Created attachment 1422938 [details]
edit network dialog

Description of problem:
By editing Network there is vNIC profiles tab that is empty even when the Network has some profiles.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.3-0.1.el7.noarch

How reproducible: always


Steps to Reproduce:
1. go to Network -> Networks
2. select ovirtmgmt network in Default DC (it should have ovirtmgmt vNIC profile) and edit it

Actual results: empty vNIC profiles tab, see attachment


Expected results: no vNIC profiles tab (only by inserting new network) or list of network's vNIC profiles is displayed

Comment 1 Dan Kenigsberg 2018-04-19 19:53:12 UTC
Are you, by any chance, using OVS(Experimental!) cluster switch type?

Does this happen on all deployments of Engine?

Comment 2 Lucie Leistnerova 2018-04-20 07:25:52 UTC
It does in every engine I tested. And the screenshot in attachment is from default ovirtmgmt network on Default dc and cluster, where I did not change anything.

Comment 3 Michael Burman 2018-04-25 07:49:19 UTC
vNIC profile sub tab was never exist on edit network flow, only on new network flow. Someone has added this on latest versions.
We need to remove vNIC profile sub tab then from the edit network flow.

Comment 4 Michael Burman 2018-05-27 08:07:03 UTC
The vNIC profile is gone now from the edit network flow(for vNIC profiles we have a dedicated tab)
Verified on - 4.2.4-0.1.el7

Comment 5 Sandro Bonazzola 2018-06-26 08:44:58 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.