Bug 1568306 - netstat -i only shows 8 characters of Iface name
Summary: netstat -i only shows 8 characters of Iface name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: net-tools
Version: 7.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Michal Ruprich 🐧
QA Contact: Ondrej Mejzlik
URL:
Whiteboard:
Depends On:
Blocks: 1568317 1585638
TreeView+ depends on / blocked
 
Reported: 2018-04-17 08:19 UTC by Ondrej Mejzlik
Modified: 2018-10-30 07:52 UTC (History)
3 users (show)

Fixed In Version: net-tools-2.0-0.24.20131004git.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1568317 1585638 (view as bug list)
Environment:
Last Closed: 2018-10-30 07:52:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3034 None None None 2018-10-30 07:52:35 UTC

Description Ondrej Mejzlik 2018-04-17 08:19:14 UTC
Description of problem:
netstat -i only shows 8 characters of Iface name.

uname -r
3.10.0-862.el7.x86_64
This does occur on RHEL-7.5

Version-Release number of selected component (if applicable):
$ rpm -qa | grep net-tools
net-tools-2.0-0.22.20131004git.el7.x86_64

How reproducible:
Easy to reproduce.

Steps to Reproduce:
1. Create new network interface with long name
   sudo ip tuntap add mode tap "osmznaku0012"
2. Assign ip address 
   sudo ifconfig osmznaku0012 192.168.15.15
3. Check
   netstat -i 

Actual results:
Interface name set to osmznaku0012 (12 chars)

$ ip a:
6: osmznaku0012: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether da:75:24:13:f4:41 brd ff:ff:ff:ff:ff:ff
    inet 192.168.15.15/24 brd 192.168.15.255 scope global osmznaku0012
       valid_lft forever preferred_lft forever

$ netstat -i
Kernel Interface table
Iface      MTU    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
enp0s31f  1500   501561      0      0 0        417744      0      0      0 BMRU
lo       65536    83722      0      0 0         83722      0      0      0 LRU
osmznaku  1500        0      0      0 0             0      0      0      0 BMU


Expected results:
Display the whole name

Additional info:

Comment 7 errata-xmlrpc 2018-10-30 07:52:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3034


Note You need to log in before you can comment on or make changes to this bug.