Bug 1568309 - stack smashing detected when attempting start a test
Summary: stack smashing detected when attempting start a test
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perftest
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Honggang LI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 08:21 UTC by Attila Fazekas
Modified: 2018-04-18 21:48 UTC (History)
5 users (show)

Fixed In Version: perftest-4.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 02:36:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Attila Fazekas 2018-04-17 08:21:09 UTC
Description of problem:


Program received signal SIGABRT, Aborted.
0x00007ffff72e0660 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x00007ffff72e0660 in raise () from /lib64/libc.so.6
#1  0x00007ffff72e1c41 in abort () from /lib64/libc.so.6
#2  0x00007ffff7322f17 in __libc_message () from /lib64/libc.so.6
#3  0x00007ffff73b255e in __fortify_fail_abort () from /lib64/libc.so.6
#4  0x00007ffff73b2522 in __stack_chk_fail_local () from /lib64/libc.so.6
#5  0x000055555555b0b5 in check_mtu ()
#6  0x000055555555754c in main ()

Version-Release number of selected component (if applicable):
perftest-3.0-4.fc27.x86_64

How reproducible:
always

Steps to Reproduce:
1.NodeA /usr/bin/ib_write_lat --ib-dev mlx4_0
2.NodeB /usr/bin/ib_write_lat 192.168.150.2


Actual results:
************************************
* Waiting for client to connect... *
************************************
*** stack smashing detected ***: <unknown> terminated


Expected results:
Does the test.

Additional info:
https://bugs.launchpad.net/ubuntu/+source/perftest/+bug/1553185
https://github.com/linux-rdma/perftest/commit/4dc033eb5ba51b4609ce20f3161a3471ce01f2e8

New upstream release available:
https://github.com/linux-rdma/perftest/releases (pre)
http://www.openfabrics.org/downloads/perftest/

Comment 1 Honggang LI 2018-04-17 08:44:52 UTC
We usually download perftest source code for OFED http://www.openfabrics.org/downloads/perftest/ .

It seems the OFED website is not keep sync with github. So, we will download the latest release of perftest from github.

Comment 2 Attila Fazekas 2018-04-17 08:53:22 UTC
The perftest-3.4 does not have the fix, I'll try the github version.

Comment 3 Attila Fazekas 2018-04-17 09:02:51 UTC
The pre release https://github.com/linux-rdma/perftest/releases/download/V4.2-0.5/perftest-4.2-0.5.gdd28746.tar.gz leads to similar issue :
https://github.com/linux-rdma/perftest/issues/26


************************************
* Waiting for client to connect... *
************************************
Couldn't allocate MR
failed to create mr
Failed to create MR
 Couldn't create IB resources

Comment 4 Honggang LI 2018-04-17 09:12:26 UTC
(In reply to Attila Fazekas from comment #3)
> The pre release
> https://github.com/linux-rdma/perftest/releases/download/V4.2-0.5/perftest-4.
> 2-0.5.gdd28746.tar.gz leads to similar issue :
> https://github.com/linux-rdma/perftest/issues/26

https://github.com/linux-rdma/perftest/pull/29

The fix had been merged. Can you please test it and feedback?

Comment 5 Attila Fazekas 2018-04-17 09:28:23 UTC
I tested the master:
./ib_write_lat 192.168.150.2

The output is much better ;-)
Looks like just 3 patch from the release.

---------------------------------------------------------------------------------------
                    RDMA_Write Latency Test
 Dual-port       : OFF		Device         : mlx4_0
 Number of qps   : 1		Transport type : IB
 Connection type : RC		Using SRQ      : OFF
 TX depth        : 1
 Mtu             : 4096[B]
 Link type       : IB
 Max inline data : 220[B]
 rdma_cm QPs	 : OFF
 Data ex. method : Ethernet
---------------------------------------------------------------------------------------
 local address: LID 0x02 QPN 0x0213 PSN 0xe1b14c RKey 0x8001100 VAddr 0x000000013a3000
 remote address: LID 0x01 QPN 0x020f PSN 0x3431a0 RKey 0x8001100 VAddr 0x0000000069f000
---------------------------------------------------------------------------------------
 #bytes #iterations    t_min[usec]    t_max[usec]  t_typical[usec]    t_avg[usec]    t_stdev[usec]   99% percentile[usec]   99.9% percentile[usec] 
Conflicting CPU frequency values detected: 2649.885000 != 2919.319000. CPU Frequency is not max.
Conflicting CPU frequency values detected: 3839.276000 != 3491.922000. CPU Frequency is not max.
 2       1000          0.75           3.75         0.77     	       0.78        	0.06   		0.82    		3.75   
---------------------------------------------------------------------------------------

Comment 7 Honggang LI 2018-04-18 02:36:43 UTC
(In reply to Attila Fazekas from comment #6)

> 
> https://github.com/linux-rdma/perftest/releases/download/V4.2-0.5/perftest-4.
> > 2-0.5.gdd28746.tar.gz can work with https://github.com/linux-rdma/perftest/pull/29 .

Fixed in perftest-4.2-1.fc29 and perftest-4.2-1.fc28

Comment 8 Attila Fazekas 2018-04-18 21:48:50 UTC
perftest-4.2-1.fc28.x86_64 worked for me.


Note You need to log in before you can comment on or make changes to this bug.