Bug 1568311 - [Netvirt] Connectivity from non-FIP instances (snat) to an external IP fails when using multiple routers
Summary: [Netvirt] Connectivity from non-FIP instances (snat) to an external IP fails ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 13.0 (Queens)
Assignee: Aswin Suryanarayanan
QA Contact: Tomas Jamrisko
URL:
Whiteboard: Netvirt
Depends On:
Blocks: 1528948
TreeView+ depends on / blocked
 
Reported: 2018-04-17 08:31 UTC by Itzik Brown
Modified: 2018-10-18 07:18 UTC (History)
7 users (show)

Fixed In Version: opendaylight-8.3.0-1.el7ost
Doc Type: Known Issue
Doc Text:
Layer 3 connectivity between nova instances across multiple subnets may fail when an instance without a floating IP tries to reach another instance that has a floating IP on another router. This occurs when nova instances are spread across multiple compute nodes. There is no suitable workaround for this issue.
Clone Of:
Environment:
N/A
Last Closed: 2018-07-19 13:53:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Robot Log (3.85 MB, text/html)
2018-04-17 08:31 UTC, Itzik Brown
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenDaylight Bug NETVIRT-1238 0 None None None 2018-05-15 15:54:07 UTC
OpenDaylight gerrit 72019 0 None None None 2018-05-15 15:54:32 UTC
Red Hat Product Errata RHBA-2018:2215 0 None None None 2018-07-19 13:53:47 UTC

Description Itzik Brown 2018-04-17 08:31:41 UTC
Created attachment 1422944 [details]
Robot Log

Description of problem:
When running the OpenDaylight external_network.robot test on HA setup - it fails.
Instances without FIP connected to one router are unable to connect to external IP.
Instance on another router is able to connect to an external IP

Version-Release number of selected component (if applicable):
opendaylight-8.0.0-5.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Run https://github.com/opendaylight/integration-test/blob/master/csit/suites/openstack/connectivity/external_network.robot
2.
3.

Actual results:


Expected results:


Additional info:

Comment 17 errata-xmlrpc 2018-07-19 13:53:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2215


Note You need to log in before you can comment on or make changes to this bug.