Bug 156836 - grub refuses to display menu on serial console
grub refuses to display menu on serial console
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks: 250490
  Show dependency treegraph
 
Reported: 2005-05-04 12:20 EDT by Phil Hollenback
Modified: 2008-05-06 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Hollenback 2005-05-04 12:20:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.9995

Description of problem:
On a system with a serial console, grub should print a menu on that console when a user presses a key at the grub 'press any key' menu.  Instead, it loads the default kernel without further user input.  If you attach a monitor/keyboard to the system and press the key there when prompted, grub displays the graphical menu.

This worked in previous versions of grub but recently has stopped working.  Thus if we don't have a video card and keyboard on a system, we can't select different boot options.

Version-Release number of selected component (if applicable):
grub-0.93-7.0-1

How reproducible:
Always

Steps to Reproduce:
1. Power up system with serial console attached
2. Wait for 'press any key' message from grub on serial console, then press any key on the serial console.

  

Actual Results:  grub stops printing 'press any key' messages and boots the default kernel.

Expected Results:  grub should have displayed a menu on the serial console.

Additional info:

grub.conf:

serial --unit=0 --speed=9600
terminal --timeout=10 serial console
default=0
timeout=15
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.6.10-0.ti.4.fc1)
        kernel /vmlinuz-2.6.10-0.ti.4.fc1 ro root=LABEL=/ acpi=on selinux=0 vdso=0 exec-shield=0 console=tty0 console=ttyS0,9600
        initrd /initrd-2.6.10-0.ti.4.fc1.img
title Fedora Core (2.6.10-0.ti1.fc1)
        kernel /vmlinuz-2.6.10-0.ti1.fc1 ro root=LABEL=/ acpi=on selinux=0 vdso=0 exec-shield=0 console=tty0 console=ttyS0,9600
        initrd /initrd-2.6.10-0.ti1.fc1.img
title Memtest86+ (1.55.1)
        kernel /memtest86+-1.55.1
Comment 1 Phil Hollenback 2005-06-13 11:24:49 EDT
Ok we've found out what the problem is here and I believe it is a bug in a
Fedora patch to grub.  The fix is to rework the patch, but at the very least
this should be documented.

I changed the release to FC3 as we have tested this on FC3 with the .95.3 grub
and verified the problem is still there.

This failure is due to an interaction between splashimage and the serial
console.  If you put a splashimage in grub.conf, this has the side effect of
turning off the menu on the serial port.  I believe the problem is this in Patch200:

stage2/builtins.c:907:
     /* FIXME: should we be explicitly switching the terminal as a
     * side effect here? */
     terminal_func("graphics", flags);

So first the docs should be changed to say that IF you put a splashimage in
grub.conf, the menu will no longer work on the serial console.  Secondly, the
Fedora changes to grub should be re-worked to not disable the menu on the serial
console in this manner.

We have worked around this for now by removing the splashimage from our grub.conf.
Comment 2 Jan Kratochvil 2005-09-09 20:29:56 EDT
Bug incl. this working workaround is still valid for: FC4 x86_64 grub-0.95-13
Please update someone "Version" field to: fc4
Comment 3 Matthew Miller 2006-07-10 19:13:00 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 4 Jan Kratochvil 2006-07-10 19:48:51 EDT
Regarding Fedora Legacy - it is still valid for fc4:
(In reply to comment #2)
> Bug incl. this working workaround is still valid for: FC4 x86_64 grub-0.95-13
> Please update someone "Version" field to: fc4
Comment 5 Matthew Miller 2006-07-11 11:38:12 EDT
Moving to FC4 as per comment #4. However, note that FC4 is scheduled to move to
Legacy support in several weeks, so this will be repeated at that point. I'm
sorry for the trouble, but can you re-check this on FC5 or newer? Thanks!
Comment 6 Jan Kratochvil 2006-07-11 12:58:43 EDT
Confirming the bug still exists in FC5 grub (there is no "update" for FC5 grub),
incl. the applicable suggested "splashimage" workaround.
Comment 7 Matthew Miller 2006-07-11 13:03:19 EDT
Thanks very much. I'm moving this to FC5 because realistically it's unlikely the
FC4 version will be updated at this point.
Comment 8 petrosyan 2008-03-10 19:35:19 EDT
Fedora Core 5 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 9 Bug Zapper 2008-04-03 21:56:17 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 10 Andrew J. Schorr 2008-04-04 09:31:44 EDT
I'm afraid we are unable to test whether this bug still exists in current
Fedora.  We have only FC6 installed at our site.
Comment 11 Jon Stanley 2008-04-05 01:01:32 EDT
Well, there's a clone of this bug against rhel5 - my guess is that it still
applies.  I unfortunately don't have hardware to test with, or else I'd confirm it.

We should probably at the very least document it, since users are expected to
tweak their grub.conf anyway for a serial console.
Comment 12 Bug Zapper 2008-05-06 11:29:27 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.