Bug 1568372 - Submit/Cancel buttons are not displayed on custom button dialogs for some service types
Summary: Submit/Cancel buttons are not displayed on custom button dialogs for some ser...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard:
: 1568371 (view as bug list)
Depends On:
Blocks: 1578954
TreeView+ depends on / blocked
 
Reported: 2018-04-17 11:20 UTC by Peter McGowan
Modified: 2019-02-11 13:59 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1578954 (view as bug list)
Environment:
Last Closed: 2019-02-11 13:59:17 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Screenshot button dialog VM provision service type (128.66 KB, image/png)
2018-04-17 11:21 UTC, Peter McGowan
no flags Details
Screenshot button dialog Ansible playbook service type (132.97 KB, image/png)
2018-04-17 11:21 UTC, Peter McGowan
no flags Details

Description Peter McGowan 2018-04-17 11:20:35 UTC
Description of problem:
The rendering of a service dialog on a custom button on a service seems to be different depending on the catalog item type. In some cases this results in no Submit/Cancel buttons, just Save/Reset/Cancel. In other cases this results in both Submit/Cancel and Save/Reset/Cancel buttons in different places

Version-Release number of selected component (if applicable):
5.9.1.2

How reproducible:
Every time

Steps to Reproduce:
1. Create a simple service dialog containing one or more text boxes.
2. Create a custom button on a service object type, that uses the new service dialog.
3. Create a service catalog item of type Ansible Playbook, and order the service
4. Create a service catalog item of type RHV/VMware (to create a VM) and order the service.
5. On each of the resulting new services, order the (same) new custom button

Actual results:
When the button is pressed on the Ansible playbook service, no Submit/Cancel buttons appear on the service dialog (see screenshot screenhot_button_dialog_ansible_playbook_service.png).

When the button is pressed on the RHV VM service, both Submit/Cancel and Save/Reset/Cancel buttons appear (see screenshot screenhot_button_dialog_vm_provision_service.png).


Expected results:
The button dialog should behave the same for all service types. Just the Submit/Cancel buttons should appear on the button dialog

Additional info:
The dialog on the Ansible playbook service seems to be rendered by the old dialog renderer, whereas the dialog on the VM service seems to be rendered by the new CFME 5.9 dialog renderer.

Comment 2 Peter McGowan 2018-04-17 11:21:10 UTC
Created attachment 1423000 [details]
Screenshot button dialog VM provision service type

Comment 3 Peter McGowan 2018-04-17 11:21:41 UTC
Created attachment 1423001 [details]
Screenshot button dialog Ansible playbook service type

Comment 4 Peter McGowan 2018-04-17 11:24:59 UTC
*** Bug 1568371 has been marked as a duplicate of this bug. ***

Comment 6 CFME Bot 2018-04-19 08:58:02 UTC
New commits detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/d5da59f6214dd06494849cf8b55cf7efb9a72023
commit d5da59f6214dd06494849cf8b55cf7efb9a72023
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Apr 18 12:44:51 2018 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Apr 18 12:44:51 2018 -0400

    Render new dialog runner for all service types.

    Also no need to show Save/reset/cancel buttons at the bottom of screen causing double set of buttons on screen, new dialog runner renders it's own form buttons.

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1568372

 app/controllers/service_controller.rb | 28 +-
 app/services/dialog_local_service.rb | 1 +
 2 files changed, 12 insertions(+), 17 deletions(-)


https://github.com/ManageIQ/manageiq-ui-classic/commit/23889eaafdfe160111987013172e2e23473df3f9
commit 23889eaafdfe160111987013172e2e23473df3f9
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Apr 18 13:50:13 2018 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Apr 18 13:50:13 2018 -0400

    Adjusted target_type value and added spec test.

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1568372

 app/services/dialog_local_service.rb | 2 +
 spec/services/dialog_local_service_spec.rb | 18 +
 2 files changed, 20 insertions(+)

Comment 8 Greg McCullough 2018-07-03 22:30:05 UTC
*** Bug 1595051 has been marked as a duplicate of this bug. ***

Comment 9 Nikhil Gupta 2018-07-04 23:47:15 UTC
*** Bug 1595051 has been marked as a duplicate of this bug. ***

Comment 10 Niyaz Akhtar Ansari 2018-09-04 12:30:37 UTC
Verified in Version 5.10.0.14.20180831154906_2f9a1dd


Note You need to log in before you can comment on or make changes to this bug.