Bug 15684 - System locks on AsusA7V when loading builtin sound
Summary: System locks on AsusA7V when loading builtin sound
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-07 22:00 UTC by Todd Nemanich
Modified: 2014-03-17 02:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-08 16:07:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from lspci -vn (2.18 KB, text/plain)
2000-08-09 17:58 UTC, Todd Nemanich
no flags Details
MSI K7TPro (MS-6330) lspci -vn (2.18 KB, text/plain)
2000-09-08 16:07 UTC, Jos Vos
no flags Details

Description Todd Nemanich 2000-08-07 22:00:04 UTC
The Asus A7V motherboard has a built in sound controller (AC'97). When
using sndconfig to try to setup this controller, my machine locked
completely. I did not respond to network or terminal actions. Another
problem related to this is that after a hard reboot the initscripts still
attempt to load the module and lock the machine.
	 Since the audio controller is part of the Via KT133 chipset this bug is
probably relevant to any KT133 based motherboard.

From /var/log/messages:

Aug  7 11:07:54 speak modprobe: /lib/modules/2.2.16-17/misc/sb.o:
Aug  7 11:07:55 speak modprobe: Hint: insmod errors can be caused by
incorrect module parameters, including invalid IO or IRQ parameters
Aug  7 11:07:55 speak rc.sysinit: Loading sound module (via82cxxx) failed
Aug  7 11:07:55 speak modprobe: init_module: Device or resource busy
Aug  7 11:07:55 speak modprobe: /lib/modules/2.2.16-17/misc/sb.o: insmod
/lib/modules/2.2.16-17/misc/sb.o failed
Aug  7 11:07:55 speak modprobe: /lib/modules/2.2.16-17/misc/sb.o: insmod
via82cxxx failed

Comment 1 Alan Cox 2000-08-08 00:09:02 UTC
That doesnt seem rational since it actually failed to load the modules in
question. Unless maybe the failure path is buggy.

This is a sndconfig bug. The sequence that should work is

modprobe sb support=1
modprobe via82cxxx (_audio with 2.4)

let me know what that does




Comment 2 Todd Nemanich 2000-08-08 01:16:40 UTC
The modprobe of the sb module seemed ok, but the system locked on the modprobe
via82cxxx. There was no kernel oops or anything.
	Also, the message segment I attached originally was from a boot sequence where
I believe I had to kill rc.sysinit (ctrl-c) so that it wouldn't modprobe the
via82cxxx because my machine was hanging when the module was being loaded (had
to hard reboot a couple times).

Comment 3 Bill Nottingham 2000-08-08 01:55:21 UTC
OK, that does sound like a driver problem. Bouncing back to the kernel. :)

Comment 4 Alan Cox 2000-08-08 13:05:52 UTC
We need to not load this driver by default then. Any attempt to fix it will take
a fair bit of time and mean backporting the native mode driver from 2.4.


Comment 5 Michael K. Johnson 2000-08-08 16:06:31 UTC
OK, kudzu will have to be changed not to load this driver
by default.  Back to you, Bill...

Comment 6 Bill Nottingham 2000-08-09 16:42:02 UTC
Fixed in current (0.67) kudzu; we don't configure the via
module by default. Users can still configure it in sndconfig
if they want to.

Comment 7 Todd Nemanich 2000-08-09 17:17:27 UTC
I'm changing the component to sndconfig because that is just as large a problem
as kudzu configuring this module.

Comment 8 Bill Nottingham 2000-08-09 17:35:26 UTC
Unfortunately, that module works for other people. :(

Comment 9 Bill Nottingham 2000-08-09 17:36:44 UTC
What does `lspci -vn' say?

Comment 10 Todd Nemanich 2000-08-09 17:45:46 UTC
Ok. Sounds good. The Asus A7V motherboard should probably be listed in the
hardware compatiblity lists as tier 2 with a note about the onboard sound. This
is a thunderbird motherboard, and since there was a note about the athelon mobos
with the 6.2 compat lists, it would go under there.

Comment 11 Todd Nemanich 2000-08-09 17:58:32 UTC
Created attachment 2314 [details]
output from lspci -vn

Comment 12 Jos Vos 2000-09-05 20:41:21 UTC
The MSI K7TPro mainboard, also based on the VIA KT133, has exactly the same
problem. I found the problem with RC1 and it also occurs in RH 6.2 with the
(update package) 2.2.16 kernel.

Comment 13 Bill Nottingham 2000-09-05 20:43:27 UTC
lspci -vn of that, please?

Comment 14 Jos Vos 2000-09-08 16:07:00 UTC
Created attachment 3338 [details]
MSI K7TPro (MS-6330) lspci -vn

Comment 15 Bill Nottingham 2001-02-07 00:28:20 UTC
sndconfig now no longer writes modules.conf until it's sure it's succeded
(as of 0.60-1); the driver itself is fixed in the currently-in-rawhide
2.4.0 kernel.


Note You need to log in before you can comment on or make changes to this bug.