Bug 1568417 - custom buttom page empty
Summary: custom buttom page empty
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Dávid Halász
QA Contact: Yadnyawalk Tale
URL:
Whiteboard:
: 1608972 (view as bug list)
Depends On:
Blocks: 1608770
TreeView+ depends on / blocked
 
Reported: 2018-04-17 13:10 UTC by Cyril Coupel
Modified: 2019-02-11 14:09 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1608770 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:09:45 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
empty drawer in frech (68.50 KB, image/png)
2018-04-17 13:10 UTC, Cyril Coupel
no flags Details
english drawer (128.37 KB, image/png)
2018-04-17 13:10 UTC, Cyril Coupel
no flags Details
fixed_proof_5.10.0.11.mp4 (1.21 MB, video/mp4)
2018-08-21 07:59 UTC, Yadnyawalk Tale
no flags Details

Description Cyril Coupel 2018-04-17 13:10:01 UTC
Created attachment 1423020 [details]
empty drawer in frech

Description of problem:
The custom buttons tree is empty from automation-> automate -> customization

Version-Release number of selected component (if applicable):
5.9.1

How reproducible:


Steps to Reproduce:
1. set the language to french
2. go to automation-> automate -> customization
3.

Actual results:
no button types displayed in the button drawer

Expected results:
as with english language, display all the button types

Additional info:

Comment 2 Cyril Coupel 2018-04-17 13:10:50 UTC
Created attachment 1423021 [details]
english drawer

Comment 6 CFME Bot 2018-04-18 11:03:50 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/7ced2f710d538baabbbaf146be17883526b722b1
commit 7ced2f710d538baabbbaf146be17883526b722b1
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Tue Apr 17 11:12:23 2018 -0400
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Tue Apr 17 11:12:23 2018 -0400

    Send the tree data for explorer trees as an object instead of JSON

    https://bugzilla.redhat.com/show_bug.cgi?id=1568417

 app/views/layouts/listnav/_explorer.html.haml | 2 +-
 app/views/layouts/listnav/_generic_object_definition_show_list_with_treeview.html.haml | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comment 10 Dávid Halász 2018-07-30 12:28:24 UTC
*** Bug 1608972 has been marked as a duplicate of this bug. ***

Comment 11 Yadnyawalk Tale 2018-08-21 07:59:51 UTC
Created attachment 1477443 [details]
fixed_proof_5.10.0.11.mp4

Fixé! Fonctionnalité de bouton personnalisée fonctionnant avec d'autres langues.
Vérifié avec français et allemand.
Vérifié le - 5.10.0.11.20180816184116_02284fe 

Fixed! Custom button functionality working with other languages.
Checked with french and german.
Verified on - 5.10.0.11.20180816184116_02284fe


Note You need to log in before you can comment on or make changes to this bug.