Bug 1568424 - Instance losing DHCP lease after reboot while dhcp container is stopped
Summary: Instance losing DHCP lease after reboot while dhcp container is stopped
Keywords:
Status: CLOSED DUPLICATE of bug 1527130
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 13:19 UTC by Roee Agiman
Modified: 2018-04-18 14:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 14:19:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Roee Agiman 2018-04-17 13:19:03 UTC
Description of problem:
Instance is unreachable after rebooting while dhcp agent is down

Version-Release number of selected component (if applicable):
openstack-neutron-12.0.1-0.20180327195360.68b8980.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Boot an instance, make sure it's active and is reachable.
2. Stop the dhcp agent (docker stop ...)
3. Reboot the instance, try to reach it again (FIP or internal, both bad)

Actual results:
Instance unreachable

Expected results:
Instance still reachable due to lease

Additional info:

Comment 1 Brian Haley 2018-04-18 14:04:10 UTC
We discussed this in the triage call this morning and the changes for the dnsmasq side car container aren't fully merged yet.  I need to find the existing bug number since this is most likely a duplicate of that.

Comment 2 Brian Haley 2018-04-18 14:19:53 UTC
Marking as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1527130 - that is tracking the containerization work for the dhcp agent.

*** This bug has been marked as a duplicate of bug 1527130 ***


Note You need to log in before you can comment on or make changes to this bug.