Bug 1568459 - [Docs][NFV] Update commands to create network for DPDK
Summary: [Docs][NFV] Update commands to create network for DPDK
Keywords:
Status: CLOSED DUPLICATE of bug 1607897
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: async
: 10.0 (Newton)
Assignee: James Smith
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 14:36 UTC by Christopher Brown
Modified: 2018-11-18 07:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 07:02:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Christopher Brown 2018-04-17 14:36:43 UTC
Description of problem:

The following instructions do not work for OSP10z6

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/network_functions_virtualization_configuration_guide/part-dpdk-configure#sect-ovs-dpdk-flavor-deploy-instance

openstack network create --provider-network-type=vlan  --provider-segment=<VLAN-ID> --provider-physical-network=tenant net1

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

[heat-admin@controller-0 ~]$ openstack network create net1 --provider:network_type=vlan  --provider:segmentation_id=1201 --provider:physical_network=tenant

Actual results:

usage: openstack network create [-h] [-f {json,shell,table,value,yaml}]
                                [-c COLUMN] [--max-width <integer>]
                                [--noindent] [--prefix PREFIX]
                                [--share | --no-share] [--enable | --disable]
                                [--project <project>]
                                [--project-domain <project-domain>]
                                [--availability-zone-hint <availability-zone>]
                                [--enable-port-security | --disable-port-security]
                                [--external | --internal]
                                [--default | --no-default]
                                [--provider-network-type <provider-network-type>]
                                [--provider-physical-network <provider-physical-network>]
                                [--provider-segment <provider-segment>]
                                [--transparent-vlan | --no-transparent-vlan]
                                <name>
openstack network create: error: unrecognized arguments: --provider:network_type=vlan --provider:segmentation_id=1201 --provider:physical_network=tenant

Expected results:

[heat-admin@controller-0 ~]$ openstack network create --provider-network-type=vlan --provider-segment=1201 --provider-physical-network=net-n0 net1

+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | UP                                   |
| availability_zone_hints   |                                      |
| availability_zones        |                                      |
| created_at                | 2018-04-17T14:34:03Z                 |
| description               |                                      |
| headers                   |                                      |
...

Comment 1 Christopher Brown 2018-04-17 14:38:38 UTC
This is the same for OSP 11 and 12.

Comment 2 Lucy Bopf 2018-04-24 02:26:19 UTC
Assigning to James for review.

James, I'm assigning you this one and bug 1525590 because they describe the same command syntax error but for different sections of the guide. It might be worth checking for any other places this syntax is used, and running this by the DFG for review.

I've flagged the fix for 10, 11, 12, and 13. Christopher confirms in comments above that the problem occurs in 10, 11, and 12; you'll need to check with the DFG whether it will also occur in the yet-to-be-released version 13.

Comment 3 Christophe Fontaine 2018-08-09 07:02:06 UTC

*** This bug has been marked as a duplicate of bug 1607897 ***


Note You need to log in before you can comment on or make changes to this bug.