Bug 1568472 - OpenShift on OpenStack install fails on OSP versions older than Pike
Summary: OpenShift on OpenStack install fails on OSP versions older than Pike
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.11.z
Assignee: Tzu-Mainn Chen
QA Contact: GenadiC
URL:
Whiteboard: aos-scalability-310
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 15:02 UTC by jmencak
Modified: 2019-01-10 09:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-10 09:03:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 7549 0 None closed Add openshift_openstack_heat_template_version option 2020-04-30 12:04:37 UTC
Red Hat Product Errata RHBA-2019:0024 0 None None None 2019-01-10 09:04:04 UTC

Description jmencak 2018-04-17 15:02:29 UTC
Description of problem:

OpenShift on OpenStack install fails on OSP versions older than Pike

How reproducible:
Always

Steps to Reproduce:
1. Try to install OCP on OSP older than Pike

Expected results:
No failure.

Additional info:
OCP on OpenStack requires at least OCP Pike for Kuryr support.  

https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_openstack/templates/heat_stack_segmentation_ids.yaml.j2#L1

It would be nice to have some support for older OSP versions.
E.g.:  https://github.com/openshift/openshift-ansible/pull/7549
or insist on pike and newer versions only if Kuryr support is required.

Comment 2 Tzu-Mainn Chen 2018-05-24 16:12:22 UTC
https://github.com/openshift/openshift-ansible/pull/7549 has been merged

Comment 3 Scott Dodson 2018-08-14 21:25:05 UTC
Should be in openshift-ansible-3.11.0-0.15.0

Comment 4 N. Harrison Ripps 2018-09-21 20:14:48 UTC
Per OCP program call on 21-SEP-2018 we are deferring Kuryr-related bugs to 3.11.z

Comment 6 Itzik Brown 2019-01-01 09:57:56 UTC
Verified that the code is included in version openshift-ansible-3.11.63-1.git.0.7dc1b73.el7.noarch

Comment 8 errata-xmlrpc 2019-01-10 09:03:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0024


Note You need to log in before you can comment on or make changes to this bug.