Bug 1568478 - Cannot choose DC/cluster/host/datastore even though they are visible in Provider view
Summary: Cannot choose DC/cluster/host/datastore even though they are visible in Provi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Boriso
QA Contact: Angelina Vasileva
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 15:14 UTC by Jan Zmeskal
Modified: 2019-08-19 11:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 15:26:37 UTC
Category: ---
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Zmeskal 2018-04-17 15:14:28 UTC
Description of problem:
When I tried to provision a VM via lifecycle, I encountered a situation where I could not choose DC/cluster/host/datastore in Environment tab of VM provision view. That is despite the infrastructure provider (RHV) has been registered in CFME for quite some time (i.e. it was not newly added). See the video reproduction for details.

Version-Release number of selected component (if applicable):
CFME 5.9.2.2.20180410215257_6961422
RHV 4.2.2.5

How reproducible:
?

Steps to Reproduce:
Honestly I don't really know how I got into such state. I suppose it's quite a rare occurrence. I am attaching logs from the appliance caught during the reproduction. Hopefully they can point you towards the cause.

Additional info:
I found out that refreshing the provider removes the issue. However I still believe that is a bug because even before I initiated the refresh, all the available DCs/clusters/hosts/datastores were visible on the provider in CFME UI.

Comment 4 Greg McCullough 2018-04-17 15:48:06 UTC
Is there an appliance we can connect to that reproduces the error?

Comment 5 Jan Zmeskal 2018-04-18 08:54:43 UTC
(In reply to Greg McCullough from comment #4)
> Is there an appliance we can connect to that reproduces the error?

Unfortunately no. Since I have refreshed relationships for the provider, I have not run into the issue again on my appliance. I know my reproduction info is really insufficient, but unfortunately that's all I've got.

Comment 6 Greg McCullough 2018-04-18 14:03:10 UTC
Having the objects inventoried and linked through Rails associations would cause them to show up in the UI, but there is also relationship metadata which if not properly set could cause this issue.

I am going to pass this over to the Providers team to review as it appears to be related to inventory collection.


Note You need to log in before you can comment on or make changes to this bug.