Bug 1568484 - Upgrade cannot be achieved when relying on current unofficial tool.
Summary: Upgrade cannot be achieved when relying on current unofficial tool.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-upgrade
Version: 27
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 15:27 UTC by ricky.tigg
Modified: 2018-06-02 21:05 UTC (History)
2 users (show)

Fixed In Version: fedora-upgrade-28.2-1.fc28 fedora-upgrade-28.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 04:06:27 UTC
Type: Bug


Attachments (Terms of Use)
Command output – conflicts (2.61 KB, text/plain)
2018-04-17 15:27 UTC, ricky.tigg
no flags Details

Description ricky.tigg 2018-04-17 15:27:09 UTC
Created attachment 1423105 [details]
Command output – conflicts

Description of problem: Upgrade cannot be achieved because of an error.
Version-Release number of selected component: fedora-upgrade.noarch 28.1-1.fc27

How reproducible:
$ su -c fedora-upgrade
... (Hit Enter twice)
What is your choice? (offline/online)  offline
usage: dnf system-upgrade [-c [config file]] [-q] [-v] [--version]
                          ...
dnf system-upgrade: error: unrecognized arguments: --distro-sync

Actual results: arguments: Above mentioned error is not relevant since expression '--distro-sync' is not specified along with 'offline'.
Expected results: No reason for error – Overall process to lead to an upgrade.

Additional info: That unofficial tool for official Fedora-supported is used since I got conflicts (attachment) using an official tool:
# dnf clean all
# dnf --refresh -y upgrade
# dnf install -y dnf-plugin-system-upgrade
# dnf system-upgrade -y download --refresh --releasever=28

Comment 1 Fedora Update System 2018-04-18 08:36:18 UTC
fedora-upgrade-28.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8bbdadbd9c

Comment 2 Fedora Update System 2018-04-18 08:36:27 UTC
fedora-upgrade-28.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a815ddfc9d

Comment 3 Fedora Update System 2018-04-18 08:36:33 UTC
fedora-upgrade-28.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a8a787ab66

Comment 4 Fedora Update System 2018-04-18 16:21:08 UTC
fedora-upgrade-28.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a8a787ab66

Comment 5 Fedora Update System 2018-04-19 01:11:34 UTC
fedora-upgrade-28.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a815ddfc9d

Comment 6 Fedora Update System 2018-04-19 01:36:44 UTC
fedora-upgrade-28.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8bbdadbd9c

Comment 7 Fedora Update System 2018-04-27 04:06:27 UTC
fedora-upgrade-28.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-06-02 21:05:11 UTC
fedora-upgrade-28.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.