Bug 1568547 - [abrt] freerdp: rdpsnd_pulse_open(): xfreerdp killed by SIGABRT
Summary: [abrt] freerdp: rdpsnd_pulse_open(): xfreerdp killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freerdp
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mads Kiilerich
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:94852e061e950444897ebb9d577...
: 1574635 1579720 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 17:51 UTC by Bugzy
Modified: 2018-08-23 10:33 UTC (History)
12 users (show)

Fixed In Version: freerdp-2.0.0-44.rc3.fc27 freerdp-2.0.0-44.rc3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-23 09:45:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (38.31 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: cgroup (200 bytes, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: core_backtrace (24.10 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: cpuinfo (941 bytes, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: dso_list (5.27 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: environ (1.44 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: maps (26.11 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: mountinfo (3.38 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: open_fds (3.12 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details
File: proc_pid_status (1.31 KB, text/plain)
2018-04-17 17:51 UTC, Bugzy
no flags Details

Description Bugzy 2018-04-17 17:51:33 UTC
Version-Release number of selected component:
2:freerdp-2.0.0-41.20180405gita9ecd6a.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        xfreerdp -decorations /w:1920 /h:1080 /kbd:0x00000409 /d:LSM /u:user /parent-window:110463618 /bpp:24 /audio-mode:0 /sound:sys:pulse /drive:media,/tmp /network:lan /cert-ignore +clipboard /port:3389 /v:windows-8 /p:*************
crash_function: rdpsnd_pulse_open
executable:     /usr/bin/xfreerdp
journald_cursor: s=2de2987d1dd7445e89ce98266326dab4;i=2d761;b=bc16b229552a4547b0ad52854ac3bc9f;m=106e1a28827;t=56a0ee2f44ce3;x=f9cf22099aff402e
kernel:         4.15.13-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            418203665

Comment 1 Bugzy 2018-04-17 17:51:40 UTC
Created attachment 1423186 [details]
File: backtrace

Comment 2 Bugzy 2018-04-17 17:51:40 UTC
Created attachment 1423187 [details]
File: cgroup

Comment 3 Bugzy 2018-04-17 17:51:41 UTC
Created attachment 1423188 [details]
File: core_backtrace

Comment 4 Bugzy 2018-04-17 17:51:42 UTC
Created attachment 1423189 [details]
File: cpuinfo

Comment 5 Bugzy 2018-04-17 17:51:43 UTC
Created attachment 1423190 [details]
File: dso_list

Comment 6 Bugzy 2018-04-17 17:51:44 UTC
Created attachment 1423191 [details]
File: environ

Comment 7 Bugzy 2018-04-17 17:51:44 UTC
Created attachment 1423192 [details]
File: limits

Comment 8 Bugzy 2018-04-17 17:51:45 UTC
Created attachment 1423193 [details]
File: maps

Comment 9 Bugzy 2018-04-17 17:51:46 UTC
Created attachment 1423194 [details]
File: mountinfo

Comment 10 Bugzy 2018-04-17 17:51:47 UTC
Created attachment 1423195 [details]
File: open_fds

Comment 11 Bugzy 2018-04-17 17:51:48 UTC
Created attachment 1423196 [details]
File: proc_pid_status

Comment 12 info@kobaltwit.be 2018-04-25 17:24:28 UTC
Similar problem has been detected:

I am using xfreerdp as backend application in krdc to connect to a remote Windows PC (Windows 7 Professional, 64-bit).

While navigating around on the Windows PC, xfreerdp frequently crashes.
It seems to happen most when content of large windows with much white background changes.
For example using Windows Explorer to navigate directories, xfreerdp regularly crashes when
double-clicking a directory. Or when reading some Windows help files and clicking on a link there
to move to a different page. Or when browsing the web and clicking a link to go to another page.

I have also seen it happen when as the result of a click a dialog box is supposed to open.

In all cases when reconnecting to the PC, the action that lead to the crash is effectively 
executed on the PC, so the new directory contents would be shown, or the new help page displayed,
the new webpage loaded, the dialog box open.

It makes xfreerdp very hard to work with. Depending on what I'm doing this can happen as much
as every few clicks.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        xfreerdp -decorations /w:1600 /h:1080 /kbd:0x00000413 /u:Geert /parent-window:169871508 /bpp:24 /audio-mode:0 /sound:sys:pulse /drive:media,/home/janssege/tmp /network:lan /rfx /cert-ignore +clipboard /port:3389 /v:w7-gnucash.kobaltwit.lan /p:****************
crash_function: rdpsnd_pulse_open
executable:     /usr/bin/xfreerdp
journald_cursor: s=4ab913d91754480cbb8147d751ec8aa7;i=1ca562;b=45114ccf4380437889234a221db281f1;m=5b1812513;t=56aaf30a92e3d;x=e8fe6e6f6f475e7e
kernel:         4.15.17-300.fc27.x86_64
package:        2:freerdp-2.0.0-41.20180405gita9ecd6a.fc27
reason:         xfreerdp killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Need Real Name 2018-05-03 18:05:15 UTC
*** Bug 1574635 has been marked as a duplicate of this bug. ***

Comment 14 laxde 2018-05-18 08:00:37 UTC
*** Bug 1579720 has been marked as a duplicate of this bug. ***

Comment 15 Alvin 2018-07-02 17:55:58 UTC
I confirm this bug on several computers. (F27 and F28) using xfreerdp through krdc or remmina.
Double clicking something in Windows Explorer is often enough to trigger it.

Comment 16 Michael DePaulo 2018-08-04 03:26:11 UTC
I think we fixed this exact issue (or a similar sound crash issue) by backporting these patches that were merged shortly after 2.0.0rc2 came out:
https://github.com/FreeRDP/FreeRDP/pull/4453

Comment 17 Fedora Update System 2018-08-20 14:40:24 UTC
remmina-1.2.31.3-1.fc27 freerdp-2.0.0-44.rc3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1a5160a24d

Comment 18 Fedora Update System 2018-08-20 14:41:26 UTC
remmina-1.2.31.3-1.fc28 freerdp-2.0.0-44.rc3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1b66de68ac

Comment 19 Fedora Update System 2018-08-22 00:33:14 UTC
freerdp-2.0.0-44.rc3.fc27, remmina-1.2.31.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1a5160a24d

Comment 20 Fedora Update System 2018-08-22 03:12:43 UTC
freerdp-2.0.0-44.rc3.fc28, remmina-1.2.31.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1b66de68ac

Comment 21 Fedora Update System 2018-08-23 09:45:31 UTC
freerdp-2.0.0-44.rc3.fc27, remmina-1.2.31.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2018-08-23 10:33:23 UTC
freerdp-2.0.0-44.rc3.fc28, remmina-1.2.31.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.