Bug 1568570 - docker run --cpu-shares=N : fails: cgroup configuration: No such device or address
Summary: docker run --cpu-shares=N : fails: cgroup configuration: No such device or ad...
Keywords:
Status: CLOSED DUPLICATE of bug 1571736
Alias: None
Product: Fedora
Classification: Fedora
Component: docker
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio Murdaca
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 19:14 UTC by Ed Santiago
Modified: 2018-05-07 13:01 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 13:01:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Ed Santiago 2018-04-17 19:14:01 UTC
# docker run --cpu-shares=1  fedora date             ! or 10, 100, 1000
    container_linux.go:247: starting container process caused "process_linux.go:258: applying cgroup configuration for process caused \"No such device or address\""
    /usr/bin/docker-current: Error response from daemon: oci runtime error: container_linux.go:247: starting container process caused "process_linux.go:258: applying cgroup configuration for process caused \"No such device or address\"".

docker-1.13.1-52.git89b0e65.fc29.x86_64

Fails under both 4.15.0-0.rc8.git0.1.fc28.x86_64 and 4.17.0-0.rc1.git0.1.fc29.x86_64

Fails with setenforce 0

Comment 1 Daniel Walsh 2018-04-17 20:15:17 UTC
Is this something that worked in previous versions? Or is this something that is broken using systemd cgroups versus cgroupfs?

Comment 2 Ed Santiago 2018-04-17 20:17:24 UTC
This is a standard docker-autotest subtest; it has been working AFAICT since docker-1.10 and possibly earlier. That makes the failure a regression.

Comment 3 sebby2k 2018-04-23 14:42:16 UTC
I get the same regression after upgrading docker to latest in Fedora 28 when attempting to start a container with '--cpu-shares' and '--memory' options.

Server:
 Version:         1.13.1
 API version:     1.26 (minimum version 1.12)
 Package version: docker-1.13.1-52.git89b0e65.fc28.x86_64
 Go version:      go1.10
 Git commit:      70d5aac-unsupported
 Built:           Fri Apr 13 05:49:55 2018
 OS/Arch:         linux/amd64
 Experimental:    false


Error:

/usr/bin/docker-current: Error response from daemon: oci runtime error: container_linux.go:247: starting container process caused "process_linux.go:258: applying cgroup configuration for process caused \"No such device or address\"".

Comment 4 David Sastre Medina 2018-05-07 13:01:34 UTC

*** This bug has been marked as a duplicate of bug 1571736 ***


Note You need to log in before you can comment on or make changes to this bug.