Bug 1568612 - "Cannot get object id" errors in log
Summary: "Cannot get object id" errors in log
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: Extensions
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 5.0-RH6
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 22:54 UTC by Jeff Fearn 🐞
Modified: 2019-06-18 04:25 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-18 04:25:07 UTC


Attachments (Terms of Use)

Description Jeff Fearn 🐞 2018-04-17 22:54:28 UTC
Description of problem:
There are some "Cannot get object id" errors in the log, need to track down what causes this.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Invalid Service Now links

Steps to Reproduce:
1. Enter an invalid SN ID.


Actual results:
log/list gets the following error:

In Bugzilla::Bug::_get_object_id, I was unable to get an id

Col: ext_bz_bug_map.ext_bz_bug_id
Value: RH-??????

Expected results:
Invalid IDs should throw an error when they are entered.

Additional info:

Comment 1 Jeff Fearn 🐞 2019-06-18 04:25:07 UTC
Turns out this is a warning when removing invalid ETs, so no issue.


Note You need to log in before you can comment on or make changes to this bug.