Bug 1568651 - 389-ds-base - tcmalloc crashes ns-slapd (may be solved by SSSD fix bz 1566782 )
Summary: 389-ds-base - tcmalloc crashes ns-slapd (may be solved by SSSD fix bz 1566782 )
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 01:29 UTC by Marc Sauton
Modified: 2018-09-24 12:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-31 15:27:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marc Sauton 2018-04-18 01:29:03 UTC
Description of problem:

tcmalloc can crash ns-slapd from 389-ds-base in various places like other components or plug-ins, with a somehow generic segfault message, most of the time out of the control of 389-ds-base itself.

this bz is to track some of those customer cases reported as ns-slapd crashes and evaluate if the performance gain is till valuable versus stability.
should the memory allocator be switchable to either tcmalloc and glibc?


Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
1. N/A
2.
3.

Actual results:

kernel: ns-slapd[128160]: segfault at 0 ip 00007f728d83f32b sp 00007f7239e02bf0 error 4 in libtcmalloc.so.4.2.6[7f728d818000+48000]


Expected results:
;-)


Additional info:

Comment 10 mreynolds 2018-04-23 13:36:20 UTC
Correct this looks like https://bugzilla.redhat.com/show_bug.cgi?id=1566782


Note You need to log in before you can comment on or make changes to this bug.