Bug 1568672 - After Removing Gateway IP of tenant network it is not possible to boot instnace
Summary: After Removing Gateway IP of tenant network it is not possible to boot instnace
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 13.0 (Queens)
Assignee: Miguel Angel Ajo
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 04:24 UTC by Eran Kuris
Modified: 2019-09-09 14:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 08:50:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eran Kuris 2018-04-18 04:24:16 UTC
Description of problem:
In DVR environment after removing gateway ip for tenant network (DVR) I could not boot instance
 


Version-Release number of selected component (if applicable):
osp13 p 
2018-04-10.2


Steps to Reproduce:
Perform the following procedure in the DVR environment.
    1. Create router (distributed = true)
    2. Create internal network and subnet.
    3. Connect the created internal network subnet to a router. 
    4. Delete "gateway_ip" of internal network subnet.
    5. Create instance.
      -> Instance creation fails on some node.

  After that, anyone cannot create a new instance on that node.


Actual results:


Expected results:


Additional info:

Comment 1 Assaf Muller 2018-04-18 14:01:10 UTC
Assigned to Miguel for triage.

Regarding (4), how did you execute that step?

As an aside, this bug report would be more valuable had it included an sosreport. Please see http://post-office.corp.redhat.com/archives/rh-openstack-dev/2018-April/msg00265.html.

Comment 3 Eran Kuris 2018-04-22 06:05:22 UTC
(In reply to Assaf Muller from comment #1)
> Assigned to Miguel for triage.
> 
> Regarding (4), how did you execute that step?
> 
> As an aside, this bug report would be more valuable had it included an
> sosreport. Please see
> http://post-office.corp.redhat.com/archives/rh-openstack-dev/2018-April/
> msg00265.html.

openstack router remove subnet Router_eNet subnet

when I get setup  I will add  sos-report

Comment 4 Eran Kuris 2018-04-25 08:50:55 UTC
could not reproduce.
Closing till we see that again.


Note You need to log in before you can comment on or make changes to this bug.