Bug 1568696 - Failed to convert app: [[Ljava.lang.Object;] warning appear in engine.log
Summary: Failed to convert app: [[Ljava.lang.Object;] warning appear in engine.log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-4.2.4
: ---
Assignee: Tomáš Golembiovský
QA Contact: Vitalii Yerys
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 07:02 UTC by Mor
Modified: 2018-06-26 08:44 UTC (History)
6 users (show)

Fixed In Version: vdsm-4.20.28-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:44:31 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
engine.log (1.42 MB, application/octet-stream)
2018-04-18 07:02 UTC, Mor
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 89882 0 ovirt-4.2 MERGED clientIF: don't dispatch on unknown VMs 2021-01-12 01:47:43 UTC
oVirt gerrit 90626 0 master MERGED vdsm: guestagent: Don't make fields a tuple 2021-01-12 01:47:43 UTC
oVirt gerrit 90885 0 ovirt-4.2 MERGED vdsm: guestagent: Don't make fields a tuple 2021-01-12 01:48:22 UTC

Description Mor 2018-04-18 07:02:34 UTC
Created attachment 1423364 [details]
engine.log

Description of problem:
Engine vds scheduled task fails to convert application name to string type. 
Warning appears in engine.log:
2018-04-18 06:43:25,893Z WARN  [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (EE-ManagedThreadFactory-engineScheduled-Thread-81) [] Failed to convert app: [[Ljava.lang.Object;] is not a string

Version-Release number of selected component (if applicable):
RHV 4.2.3-0.1.el7

How reproducible:
100%

Steps to Reproduce:
Appear during scheduled thread. Seems to be host related.

Actual results:
Failure in conversion.

Expected results:
Success.

Additional info:

Comment 1 Michal Skrivanek 2018-04-19 07:01:12 UTC
please attach vdsm logs, ideally in debug

Comment 2 Mor 2018-04-22 11:26:36 UTC
From which host do you need the logs?

Comment 3 Michal Skrivanek 2018-04-22 17:13:03 UTC
any host which talks to this engine and triggers the err

Comment 4 Michal Skrivanek 2018-04-24 08:53:50 UTC
seems the list is reported wrongly once guest agent stops reporting data
reporduced by running ovirt-ga to get appsList [...] and then stop it while VM is still running, you get [[...]] which breaks engine assumption

Comment 5 Yaniv Kaul 2018-04-24 11:05:01 UTC
This is not a blocker nor an exception, yet it is targeted for 4.2.3?

Comment 6 Michal Skrivanek 2018-04-24 13:16:25 UTC
it' minor, but raising a lot of false alarms. 
Same for the exception on vdsm side about onLibvirtLifecycleEvent. If they can make it in in time then they should

Comment 7 Francesco Romani 2018-04-24 13:34:17 UTC
vdsm patch ready to merge if exception flag approved

Comment 8 Vitalii Yerys 2018-06-18 17:50:48 UTC
Verified with:  vdsm-4.20.31-1.el7ev.x86_64

Steps to reproduce on vdsm-4.20.27.1-1.el7ev.x86_64:
1. start vm with guest agent.
2. On the vm stop the GA service (systemctl stop ovirt-guest-agent.service)
3. In this point it is required to wait for few min till engine tries to update info on GA. (in my case ~3min)
4. Verify engine log:

2018-06-18 20:47:01,678+03 WARN  [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (EE-ManagedThreadFactory-engineScheduled-Thread-47) [] Failed to convert app: [[Ljava.lang.Object;] is not a string

5. Get vm stats on the host (appslist is in double list [[...]]):

vdsm-client VM getStats vmID='{vm_id}' | grep appsList -A 6
        "appsList": [
            [
                "kernel-3.10.0-693.11.1.el7", 
                "ovirt-guest-agent-common-1.0.14-3.el7ev", 
                "kernel-3.10.0-693.el7"
            ]
        ], 


Result: Bug is no longer present in vdsm-4.20.31-1.el7ev.x86_64, resolution - Verified.

Comment 9 Sandro Bonazzola 2018-06-26 08:44:31 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.