Bug 1568697 - Creating new host with host params using user data template does not work [NEEDINFO]
Summary: Creating new host with host params using user data template does not work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.3.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 07:03 UTC by Amaani S Karimi
Modified: 2021-01-19 21:34 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-19 21:34:03 UTC
Target Upstream Version:
bkearney: needinfo? (mmccune)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 19465 0 Normal New User data template rendering does not render host parameters 2021-01-08 13:53:54 UTC
Red Hat Knowledge Base (Solution) 4201551 0 Customize or extend None Creating a new host with Host Parameters using User Data template does not work in Red Hat Satellite 6. 2019-06-06 04:32:37 UTC

Description Amaani S Karimi 2018-04-18 07:03:00 UTC
Description of problem:

The host parameters is not read by the user data template renderer.

Version-Release number of selected component (if applicable):

Red Hat Satellite 6.3.1

How reproducible:

clone the Satellite Kickstart Default User Data and added to the bottom of the template this config:

---
<% if host_param_true?('ansible_tower_provisioning') -%>
    <%= save_to_file('/root/ansible_provisioning_call.sh', snippet('ansible_tower_callback_script')) %>
    /root/ansible_provisioning_call.sh
<% end -%>

then set the host parameter ansible_tower_provisioning to true in the GUI and click create.

The template renders fine in satellite and shows that this was added:

 # update all the base packages from the updates repository
 yum -t -y -e 0 update
  


cat << EOF > /root/ansible_provisioning_call.sh

#!/bin/sh

echo "Calling Ansible AWX/Tower provisioning callback..."
/usr/bin/curl -v -k -s --data "host_config_key=TEST123" https://ansible.example.com/api/v2/job_templates/123/callback/
echo "DONE"
EOF
    /root/ansible_provisioning_call.sh

---

But the user-data in /dev/sr0 on the host shows me nothing added:
---

      # update all the base packages from the updates repository
    yum -t -y -e 0 update

---


Actual results:

Host parameter added to user data template shows added and renders fine in satellite WebUI but shows nothing added on Host.

Expected results:

Host parameter added to user data template shows added and renders fine in satellite WebUI but should show same on Host.

Comment 2 Ondřej Pražák 2018-09-25 10:59:14 UTC
Connecting redmine issue http://projects.theforeman.org/issues/19465 from this bug

Comment 4 Bryan Kearney 2019-11-04 14:34:00 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 5 Bryan Kearney 2019-12-03 12:53:31 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 9 dyuen 2020-05-20 13:25:16 UTC
Here is the comment from Bell case# 02590962

comment #12
We do have several specific use cases that demand the host-level parameters. But we recently came to realize this bug is only affecting image-based provisioning process with cloud-init. So we've come up with an alternate solution that leverages kickstart for our VM provisioning. Host-level parameter can be successfully rendered in kickstart template. Therefore this is a verified workaround for our use case. You can close the ticket now.

comment#7
"Host Group/Location/Domain/Subnet-level parameters all work well and we have been using them since the beginning. But recently we have a use-case that a host-level parameter is required for our host provisioning process. Since the "Creating Host" page in Satellite UI has the option to input a Host Parameter, we suppose this is a supported feature, except that it doesn't work as expected. In addition, we found this bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1568697 which makes us to conclude that it is a *known bug*. But somehow the status of it is "CLOSE/WONT FIX". Could you please help us to address this ?"

Comment 12 Mike McCune 2020-12-09 22:17:35 UTC
Upon review of our valid but aging backlog the Satellite Team has concluded that this Bugzilla does not meet the criteria for a resolution in the near term, and are planning to close in approximately a month. If you have any concerns about this, please contact your Red Hat Account team.  Thank you.

Comment 13 Mike McCune 2021-01-19 21:25:51 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact your Red Hat Account Team. Thank you.


Note You need to log in before you can comment on or make changes to this bug.