Bug 1568706 - If network-environment.yaml is missing in the plan, the validator seems hung [NEEDINFO]
Summary: If network-environment.yaml is missing in the plan, the validator seems hung
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Gaël Chamoulaud
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 07:16 UTC by Udi
Modified: 2021-04-23 05:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-28 00:09:01 UTC
Target Upstream Version:
jbuchta: needinfo? (mbarnett)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 547518 0 'None' ABANDONED Port the network env validation to use parameters 2020-05-27 10:26:13 UTC

Description Udi 2018-04-18 07:16:38 UTC
Description of problem:
If you run the validator "Validate the Heat environment file for network configuration" on a plan that has no network-environment.yaml at all, the failure will not be shown until you press F5. 

In OSP13 this file doesn't exist by default, instead there is a network-environment.j2.yaml and it looks like the validator is not even looking into it.


Version-Release number of selected component (if applicable):
openstack-tripleo-validations-8.4.0-1.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Make sure the plan doesn't have a network-environment.yaml in it
2. Run the validator from the GUI


Actual results:
The GUI doesn't show that the validator failed. If you press F5 you'll see the error which says that the file network-environment.yaml wasn't found.

Comment 1 Udi 2018-04-18 07:21:51 UTC
Florian, is the validator supposed to be looking into network-environment.yaml or network-environment.j2.yaml? What is the relationship between the 2 files (is one created from the other, and when)? Where are users supposed to put in their configurations in OSP13?

Comment 15 Kevin Carter 2020-05-28 00:09:01 UTC
I've marked this issue as "WONTFIX." The issue is >2 years old, the attached patch has been abandoned, and the underlying components fundamentally no longer exists in Master. If this issue is still relevant, and something we need to be work on directly in earlier releases, please reopen it.


Note You need to log in before you can comment on or make changes to this bug.