Bug 1568739 - [virtio-win][vioscsi] Win7/win2008 guest BSOD after the first reboot when installing os with virtio_scsi
Summary: [virtio-win][vioscsi] Win7/win2008 guest BSOD after the first reboot when ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 08:15 UTC by xiagao
Modified: 2018-10-30 16:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2018-10-30 16:21:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
BSOD (589.84 KB, image/png)
2018-04-18 08:15 UTC, xiagao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3413 None None None 2018-10-30 16:22:51 UTC

Description xiagao 2018-04-18 08:15:56 UTC
Created attachment 1423385 [details]
BSOD

Description of problem:
BSOD during install win7-64 guest with virtio_scsi

Version-Release number of selected component (if applicable):
virtio-win-prewhql-150

How reproducible:
100%

Steps to Reproduce:
1.install guest with virtio_scsi device
/usr/libexec/qemu-kvm \
    -name 'avocado-vt-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga std  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_daVVLT/monitor-qmpmonitor1-20180417-050911-yJSIqdXq,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_daVVLT/monitor-catch_monitor-20180417-050911-yJSIqdXq,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=0x3 \
    -drive id=drive_image1,if=none,snapshot=off,aio=threads,cache=none,format=qcow2,file=/home/kvm_autotest_root/images/win7-64-sp1-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:c7:c8:c9:ca:cb,id=idYq3Z7V,vectors=4,netdev=id5i7DUY,bus=pci.0,addr=0x4  \
    -netdev tap,id=id5i7DUY \
    -m 8192  \
    -smp 8,maxcpus=8,cores=4,threads=1,sockets=2  \
    -cpu 'Broadwell',hv_relaxed,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/ISO/Windows7/en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
    -drive id=drive_unattended,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/windows/virtio-win-prewhql-0.1-150.iso  \
    -device ide-cd,id=unattended,drive=drive_unattended,bus=ide.1,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off,strict=off \
    -enable-kvm -monitor stdio

2.
3.

Actual results:
Can't finish installation. Guest BSOD after the first reboot.
Error Message:  
IRQL_NOT_LESS_OR_EQUAL

Expected results:
Installation success. 

Additional info:
1 hit it on win2008/win7/win2008r2
2 din't hit this issue with build149, so it is a regression

Comment 3 Vadim Rozenfeld 2018-04-22 09:49:53 UTC
How about win8/win10? Do you they dave the same problem? Where I can get that 
virtio-win-prewhql-0.1-150.iso image from?

Thanks,
Vadim.

Comment 4 xiagao 2018-04-23 02:57:01 UTC
(In reply to Vadim Rozenfeld from comment #3)
> How about win8/win10? Do you they dave the same problem? Where I can get
> that 
> virtio-win-prewhql-0.1-150.iso image from?
> 
> Thanks,
> Vadim.


Didn't hit this issue on win8.1-32,win8-64 and win10-32/64.

You can get the iso in attachment.

By the way, this bug can be reproduced not only by automation but also by manual.

Comment 5 xiagao 2018-04-23 03:12:54 UTC
(In reply to xiagao from comment #4)
> (In reply to Vadim Rozenfeld from comment #3)
> > How about win8/win10? Do you they dave the same problem? Where I can get
> > that 
> > virtio-win-prewhql-0.1-150.iso image from?
> > 
> > Thanks,
> > Vadim.
> 
> 
> Didn't hit this issue on win8.1-32,win8-64 and win10-32/64.
> 
> You can get the iso in attachment.

The file is too big to upload. You can also get it by nfs server.
10.73.194.27:/vol/s2kvmauto/iso/windows/

> 
> By the way, this bug can be reproduced not only by automation but also by
> manual.

Comment 6 Yu Wang 2018-04-27 06:56:55 UTC
install guest successfully on win7-32, win2008-32/64 and 2008r2 , no BSOD occured when installing guests with build 151,

So this bug has been fix.
Change status to verified.

Thanks
Yu Wang

Comment 7 Vadim Rozenfeld 2018-04-30 10:35:51 UTC
(In reply to Yu Wang from comment #6)
> install guest successfully on win7-32, win2008-32/64 and 2008r2 , no BSOD
> occured when installing guests with build 151,
> 
> So this bug has been fix.
> Change status to verified.
> 
> Thanks
> Yu Wang

Thank you.
Vadim.

Comment 8 Danilo Cesar Lemes de Paula 2018-08-21 14:13:48 UTC
Can we have QA, PM and Release flags for this, please?

Comment 10 errata-xmlrpc 2018-10-30 16:21:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3413


Note You need to log in before you can comment on or make changes to this bug.