Bug 1568747 - Can not update a bug's comment using api on https://beta-bugzilla.redhat.com/
Summary: Can not update a bug's comment using api on https://beta-bugzilla.redhat.com/
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 08:37 UTC by Shiyi Yuan
Modified: 2018-06-01 03:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 03:15:53 UTC


Attachments (Terms of Use)

Description Shiyi Yuan 2018-04-18 08:37:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jeff Fearn 🐞 2018-04-18 09:37:03 UTC
This works for me.

$ ../rpc.pl 
Connecting to https://beta-bugzilla.redhat.com/jsonrpc.cgi
$VAR1 = 'Bug.update';
$VAR2 = {
          'ids' => '1285621',
          'comment_is_private' => {
                                    '8861687' => 1
                                  }
        };

{"version":"1.1","result":{"bugs":[{"changes":{},"last_change_time":"2018-04-18T09:14:37Z","id":1285621,"alias":[]}]}}

Comment 2 Jeff Fearn 🐞 2018-04-19 03:15:53 UTC
IRC chat reveals this is now working, maybe a post upgrade sync issue.


Note You need to log in before you can comment on or make changes to this bug.