Bug 1568752 - [virtio-win][viorng] Failed to install viorng driver in win8.1-32 guest
Summary: [virtio-win][viorng] Failed to install viorng driver in win8.1-32 guest
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 08:49 UTC by xiagao
Modified: 2018-06-25 07:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-25 07:49:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
detailed failed info (196.58 KB, image/png)
2018-04-18 08:49 UTC, xiagao
no flags Details

Description xiagao 2018-04-18 08:49:33 UTC
Created attachment 1423389 [details]
detailed failed info

Description of problem:
Install a new win8.1-32 guest,and then install prewhql-150 viorng driver which will fail.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-150


How reproducible:
100%

Steps to Reproduce:
1.Install a new win8.1-32 guest
2.Install viorng driver
3.

Actual results:
failed, detailed info pls check attachment.

Expected results:
success

Additional info:
1.It's successful to update viorng to 150 version in win8.1-32.
2.win8.1-64,win8-32,win2012-r2 didn't hit this issue.
3.Didn't hit it in 149,so it's a regression

Comment 3 Gal Hammer 2018-04-24 08:43:27 UTC
Can you please attach the setupapi.dev.log file?

Comment 4 xiagao 2018-04-26 03:01:03 UTC
(In reply to Gal Hammer from comment #3)
> Can you please attach the setupapi.dev.log file?

I tried many times to reproduce it,but failed.
And the env has been lost as the host has been returned to beaker. :(

But I found the dpinst.log , I hope it is useful.

INFO:   04/17/2018 07:58:54
INFO:   Product Version 2.1.0.0.
INFO:   Version: 6.0.6000 
INFO:   Platform ID: 2 (NT)
INFO:   Service Pack: 0.0
INFO:   Suite: 0x0100, Product Type: 1
INFO:   Architecture: X86.
INFO:   Interactive Windows Station
INFO:   Command Line: 'C:\dpinst.exe  /A /PATH E:\viorng\w8.1\x86 /C /LM /Q /F'
INFO:   DPInst is not multi-lingual.
INFO:   ****************************************
INFO:   Option set: dumping log info to console.
INFO:   Current working directory: 'C:\'
INFO:   Running on path 'E:\viorng\w8.1\x86'
INFO:   User UI Language is 0x409.
INFO:   Install option set: Running in quiet mode. Suppressing Wizard and OS popups.
INFO:   Install option set: legacy mode on.
INFO:   Install option set: Force install if driver is not better.
INFO:   Install option set: Suppress Add or Remove Programs entries.
INFO:   Install option set: Install all driver packages or none.
INFO:   Found driver package: 'E:\viorng\w8.1\x86\viorng.inf'.
INFO:   Preinstalling 'e:\viorng\w8.1\x86\viorng.inf' ...
INFO:   ENTER:  DriverPackagePreinstallW
INFO:   Driver package is already preinstalled 'e:\viorng\w8.1\x86\viorng.inf'.
SUCCESS:e:\viorng\w8.1\x86\viorng.inf is preinstalled.
INFO:   RETURN: DriverPackagePreinstallW  (0xB7)
INFO:   ENTER:  DriverPackageGetPathW
INFO:   RETURN: DriverPackageGetPathW  (0x0)
INFO:   ENTER:  DriverPackageInstallW
WARNING:DRIVER_PACKAGE_LEGACY_MODE flag set but not supported on Plug and Play driver on VISTA. Flag will be ignored.
INFO:   Installing INF file 'e:\viorng\w8.1\x86\viorng.inf' (Plug and Play).
INFO:   Looking for Model Section [RedHat.NTx86.6.2]...
INFO:   Installing devices with Id "PCI\VEN_1AF4&DEV_1005&SUBSYS_00041AF4&REV_00" using INF "C:\Windows\System32\DriverStore\FileRepository\viorng.inf_x86_f738ca9a53b5a48c\viorng.inf".
INFO:   ENTER UpdateDriverForPlugAndPlayDevices...
ERROR:  RETURN UpdateDriverForPlugAndPlayDevices. (Error code 0xE0000234: Driver is not intended for this platform.)
ERROR:  Installation failed. (Error code 0xE0000234: Driver is not intended for this platform.)
ERROR:  PnP Install failed. (Error code 0xE0000234: Driver is not intended for this platform.)
INFO:   Attempting to rollback ...
INFO:   No devices to rollback
INFO:   RETURN: DriverPackageInstallW  (0xE0000234)
INFO:   Returning with code 0x80010000
INFO:   04/17/2018 07:58:56

Comment 5 xiagao 2018-04-26 05:39:44 UTC
qemu cmd line:

/usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga std  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_EuUVSB/monitor-qmpmonitor1-20180417-075543-bMgDaVb1,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_EuUVSB/monitor-catch_monitor-20180417-075543-bMgDaVb1,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idnJNveK  \
    -chardev socket,id=serial_id_serial0,path=/var/tmp/avocado_EuUVSB/serial-serial0-20180417-075543-bMgDaVb1,server,nowait \
    -device isa-serial,chardev=serial_id_serial0 \
    -object rng-random,filename=/dev/random,id=passthrough-CEvtz4Jc \
    -device virtio-rng-pci,id=virtio-rng-pci-XpI6jZOo,rng=passthrough-CEvtz4Jc,bus=pci.0,addr=0x3  \
    -chardev socket,id=seabioslog_id_20180417-075543-bMgDaVb1,path=/var/tmp/avocado_EuUVSB/seabios-20180417-075543-bMgDaVb1,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20180417-075543-bMgDaVb1,iobase=0x402 \
    -device ich9-usb-ehci1,id=usb1,addr=0x1d.7,multifunction=on,bus=pci.0 \
    -device ich9-usb-uhci1,id=usb1.0,multifunction=on,masterbus=usb1.0,addr=0x1d.0,firstport=0,bus=pci.0 \
    -device ich9-usb-uhci2,id=usb1.1,multifunction=on,masterbus=usb1.0,addr=0x1d.2,firstport=2,bus=pci.0 \
    -device ich9-usb-uhci3,id=usb1.2,multifunction=on,masterbus=usb1.0,addr=0x1d.4,firstport=4,bus=pci.0 \
    -drive id=drive_image1,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=/home/kvm_autotest_root/images/win8-32.1-virtio.qcow2 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=0x4 \
    -device virtio-net-pci,mac=9a:b2:b3:b4:b5:b6,id=idX4MkaW,vectors=4,netdev=id0KHQhz,bus=pci.0,addr=0x5  \
    -netdev tap,id=id0KHQhz,vhost=on,vhostfd=21,fd=20 \
    -m 4096  \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2  \
    -cpu 'SandyBridge',+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/windows/winutils.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bootindex=1,bus=ide.0,unit=0 \
    -drive id=drive_virtio,if=none,snapshot=off,aio=native,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/windows/virtio-win-prewhql-0.1-150.iso \
    -device ide-cd,id=virtio,drive=drive_virtio,bootindex=2,bus=ide.0,unit=1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm

Comment 6 lijin 2018-06-25 07:49:15 UTC
As this issue can not be reproduced and it works well for recent builds, I will close it.

Feel free to re-open it if anyone hit it again.


Note You need to log in before you can comment on or make changes to this bug.